LAN file transfer speed is slow

9.0.x
help

#1

owncloud9.0 latest version has been tested and found that within the network transmission speed is very slow , like a snail . What can be improved ?


Slow Upload Speeds
#2

How fast/slow is your transfer? Can you give numbers? And what do you upload/download one large file, a large number of small files?

Many small files are not very fast or there are many ways to improve the performance (optimize database cache, use redis for file-locking, ...)


#3

Size 600M ISO file , use owncloud windows synchronization tools , network cable network transmission speed is 1M / s, for our intranet gigabit network devices, it is somewhat difficult


#4

So 1 MB/s instead of >20MB/s? Can you also transfer a file to the server with other protocols to have a comparison (and to exclude network configuration issues).

Can you monitor your server and see if any process consumes all the memory/cpu?

I haven't tried yet on a local Gbit-network. But I already reached 6-7 MB/s via public internet (it's megabytes/s not megabit!).


#5

can you give us some more informations about your network- and server-setup?

because: i've tried 9.0.4 and 9.1.0 (non RC) in a GBi-network, and i had a throughput of about 80MBytes/s.

and even when OC is on the same hypervisor, i reach up to 600MBytes/s... so i dont think that this might be an ownCloud issue by itself, more likely to check apache/mysql/network-configurations.


#6

Heya all,

I was having similar problem, on my case upload speed was about 100kb/s maximum, no matter what i did ow where i done transfer, tried 4 different Internets, places, peoples, etc.. with curl i managed get 600kb/s. after 2 days of tuning different setting only way i was managed to get it working was to force owncloud going trough reverse proxy, it fixed all speed issues in browser usage. upload speed improved from 100kb/s to 2000-5000(max)kb/s and download speed topped up internet connection max speed on this case it was 100Mbit/s.

Just a tip to people having similar problems! remember to change also ow vhost to use plain http and let proxy handle the ssl/http2 this is very important. :slight_smile:

my system ubuntu16, php7(from dist), ow9.1(moved from old system 8.0 and upgraded to 9.0 -> 9.1), nginx(from dist), redis(from dist) running on LXC container under ProXmoX.