Last version of Raspbian can't manage PHP 5


#1

I recently bought a Raspberry Pi 3 B and installed its the last OS, Raspbian Stretch 2018-03-13. My idea was to use it to run ownCloud but when I try to install I get a list of depends which are not installable, mostly php5.

I saw in the raspberry.org forum that PHP5 is no longer available, since it uses now the latest version, PHP7.

So, is there a way to solve this keeping my current OS or should I install an older version in order to run PHP5 and so ownCloud?

Here is the dependencies which I can't install:

The following packages have unmet dependencies:

 owncloud : Depends: php-assetic but it is not going to be installed
            Depends: php-doctrine-dbal (< 2.5) but 2.5.4-2 is to be installed
            Depends: php-opencloud but it is not going to be installed
            Depends: php-pimple (< 2) but it is not going to be installed
            Depends: php5 (>= 5.3.8) but it is not installable
            Depends: php5-cli but it is not installable
            Depends: php5-gd but it is not installable
            Depends: php5-json but it is not installable
            Depends: php5-mysql but it is not installable or
                     php5-pgsql but it is not installable or
                     php5-sqlite but it is not installable
            Recommends: exim4 but it is not going to be installed or
                        mail-transport-agent
            Recommends: php-aws-sdk (< 3) but it is not going to be installed
            Recommends: php-crypt-blowfish (>= 1.1.0~RC2-2~) but it is not going to be installed
            Recommends: php-dropbox but it is not going to be installed
            Recommends: php-google-api-php-client (< 1) but it is not going to be installed
            Recommends: php5-apcu but it is not installable or
                        php5-xcache but it is not installable
            Recommends: php5-curl but it is not installable
            Recommends: php5-imap but it is not installable
            Recommends: php5-intl but it is not installable
            Recommends: php5-ldap but it is not installable
            Recommends: php5-mcrypt but it is not installable
            Recommends: smbclient but it is not going to be installed

#2

From what i know the owncloud package provided at the official ownCloud repositories doesn't provide such dependencies like to php-assetic. You could try to research where this "owncloud" package is coming from and contact the maintainer of this package and let him/her know about this issue.


#3

Hi Zuzen,

I'm in the exact same case. Looks like the package available in the repo is still broken, did you notify the maintainer ?
Meanwhile it's possible to install Owncloud by downloading it on it's official website. More info here : https://www.youtube.com/watch?v=0U7NATfeTxg

Thanks for your answers,
ttdm