Ldap app problem..don't sync users :(((


#1

Steps to reproduce

  1. Install fresh OC 10.0.2
  2. Install Ldap app
  3. Configure the integration with Active Directory with Windows Server 2012 R2, witha specific group, Verify settings and count users = 7 users found..the configuration work fine..

Expected behaviour

Sync the users in a specific group and the user can use user and password of your pcs.

Actual behaviour

Don't sync the users in the users page.

Server configuration

Operating system: Ubuntu 16.04 TLS

Web server: Apache 2.4.18

Database:Mysql

PHP version:7.0.18

ownCloud version: 10.0.2

Updated from an older ownCloud or fresh install: Fresh

Where did you install ownCloud from:zip

i'm so frusted beacuse is the third verison with problem with ldap.. I'm forced to install version 9
thanks


#2

i tried
sudo -u www-data php occ user:sync "OCA\User_LDAP\User_Proxy"

and i received this output in red

[Symfony\Component\Debug\Exception\FatalThrowableError]
Call to a member function getSearchTerms() on null


#3

i installed an fresh 9.1.6
enabled the ldap app with the same configuration of AD and work fine


#4

i tried upgrade to 10.0.2 the fresh 9.1.6 but the problem persist ..


#5

To my understanding the user is synced as soon as he logs in at ownCloud.
At least this worked for me.

User logs in with his LDAP credentials and only then the user is created in ownCloud.


#6

don't see the users of active directory in users dashboard


#7

which version of OC you have?
Active directory of Windows Server 2012 R2?


#8

Logs or it didn't happen. It works for me, and I can't debug with such a little information.


#9

i send to you the logs


#10

which version of OC you have?
Active directory of Windows Server 2012 R2?

It is ownCloud 10.0.2 with samba 4...

I am not sure about the difference betwen AD and 2012R2.


#11

The latest code seems to have patched the issue, or at least where the logs are complaining. Note that it isn't in the marketplace yet.

Do you have several LDAP configurations maybe? Checking information for https://github.com/owncloud/user_ldap/pull/101 which isn't released yet.


#12

ok install the 9.X ..
thanks @jvillafanez