LDAP Authentication missing after upgrade 10.0.0.7


#1

I upgrade my ownCloud server tonight from 10.0.4.4 to 10.0.0.7 using the web updater and the LDAP authentication is no longer there. The authentication page is gone and cannot configure. What happened? The upgrade appears to have gone well.


#2

Never mind, I'm sorry for the post, I found it in the release notes.


#3

Can you point me in the right direction? I searched the release notes and can't find any reference to this. My last upgrade (to 10.0.4) resulted in a loss of LDAP. Because certain shares were tied to LDAP groups, people lost their shares and had to re-download entire folders once the LDAP plugin was re-established (by disabling and re-enabling the plugin - I took a chance and this worked, but it was pretty terrifying there for a bit). Not looking forward to repeating this. Thx.


#4

What I found in the release notes is that LDAP was moved to the Market Place, I went there and found it not to be installed. Reinstalled and worked fine after that. I appears that the upgrade from 10.0.0.4 to 10.0.7 removed the LDAP plugin and a couple others I had installed.


#5

Ah, yes. Looks like that happened in 10.0.1. I didn't get bit until 10.0.4 for some reason. The marketplace said LDAP plugin was installed, yet it wasn't working until I disabled/enabled. My previous configuration was retained.

Every time I upgrade, something that seems to go wrong. Think I'm holding off for a while moving to 10.0.7. Just reading through the release notes gives me a sinking feeling in the pit of my stomach.

Thanks for the heads up.