LDAP Authentication


#1

Hello,

I made a ldap authentication. It’s working. But when i make a fisrt authentication, the user name is an UUID (LDAP entryUUID object). I can rname it in the users panel.

Is it normal (exepected behaviour) or a bad setting

Sorry if my english is not correct, i’m french

Thanks for your answers


#2

Hi,
You can set an attribute in the ownCloud ldap server expert settings.
Enter in the Internal Username: field something like samaccountname to see the users names instead of the number and letter string.
https://doc.owncloud.com/server/10.0/admin_manual/configuration/user/user_auth_ldap.html


#3

You can set an attribute in the ownCloud ldap server expert settings

Note that, although possible, it's highly recommended to leave it with the default value.
The username (not the displayname) MUST be unique; using the entryUUID guarantees this for the LDAP backend, and also is unlikely that other user backends use the same username for any of their username. This will be less problematic in the long run.


#4

You can add any parameter in your expert tab that should be unique, but once you added this should not be changed otherwise you will have a lot of problems.

Renaming in the panel should not be possible because next time the user logs in will be renamed again.

As an administrator, you should choose what is the best recommendation, but we recommend, as you said, to have something unique and UUID is for sure unique.