Ldap configuration

ldap
help

#1

"Username" why I don't see the Username of user (field in LDAP)?


#2

Please fill out the shown template when creating a new thread instead of deleting it. Up to now its not even known which oC version you're running.

It might be also useful to provide the LDAP configuration you're using.


#3

Hi aley. Try to set in the expert tab, internal Username attibute = uid if you are using an LDAP or sAMAccountName if you are using an Active Directory. Hope it can help you

Cheers

davitol


#4

I have the same issue. I have tested with uid, cn and mail and nothing happened.. I'm using OC 9 and FreeIpa 4 like ldap backend.

| Configuration | s01 |
+-------------------------------+--------------------------------------------------------------------+
| hasMemberOfFilterSupport | 1 |
| hasPagedResultSupport | |
| homeFolderNamingRule | attr:cn |
| lastJpegPhotoLookup | 0 |
| ldapAgentName | uid=cons,cn=users,cn=accounts,dc=xxx |
| ldapAgentPassword | *** |
| ldapAttributesForGroupSearch | |
| ldapAttributesForUserSearch | |
| ldapBackupHost | |
| ldapBackupPort | |
| ldapBase | cn=accounts,dc=xxx |
| ldapBaseGroups | cn=groups,cn=accounts,dc=xxx |
| ldapBaseUsers | cn=users,cn=accounts,dc=xxx |
| ldapCacheTTL | 600 |
| ldapConfigurationActive | 1 |
| ldapDynamicGroupMemberURL | |
| ldapEmailAttribute | mail |
| ldapExperiencedAdmin | 1 |
| ldapExpertUUIDGroupAttr | |
| ldapExpertUUIDUserAttr | |
| ldapExpertUsernameAttr | cn |
| ldapGroupDisplayName | cn |
| ldapGroupFilter | (&(objectclass=ipausergroup)(!(cn=teachers))) |
| ldapGroupFilterGroups | |
| ldapGroupFilterMode | 0 |
| ldapGroupFilterObjectclass | ipausergroup |
| ldapGroupMemberAssocAttr | member |
| ldapHost | ldap://ipa.xxx |
| ldapIgnoreNamingRules | |
| ldapLoginFilter | (&(memberof=cn=adminusers*)(uid=%uid)(!(nsAccountLock=True))) |
| ldapLoginFilterAttributes | |
| ldapLoginFilterEmail | 0 |
| ldapLoginFilterMode | 0 |
| ldapLoginFilterUsername | 1 |
| ldapNestedGroups | 0 |
| ldapOverrideMainServer | |
| ldapPagingSize | 1000 |
| ldapPort | 389 |
| ldapQuotaAttribute | |
| ldapQuotaDefault | |
| ldapTLS | 0 |
| ldapUserDisplayName | cn |
| ldapUserDisplayName2 | mail |
| ldapUserFilter | (&(memberof=cn=adminusers*)(!(nsAccountLock=True))) |
| ldapUserFilterGroups | |
| ldapUserFilterMode | 0 |
| ldapUserFilterObjectclass | posixaccount |
| ldapUuidGroupAttribute | auto |
| ldapUuidUserAttribute | auto |
| turnOffCertCheck | 0 |
| useMemberOfToDetectMembership | 1 |
+-------------------------------+--------------------------------------------------------------------+


#5

Hi @marciofoz

Did you click on the Clear Buttons in the expert tab after setting the 'uid' value in the internal username attribute textbox?


#6

Hi @davitol.
After I have clicked works, great !!
Thank you!