LDAP user on sub-sub Active Directory OU not found

expert
ldap
9.1.x
help

#1

Please help us by providing the following info. Before posting please also check the pinned "Known issues" threads and make sure that you're running the latest available version for your oC release: https://owncloud.org/changelog/

Steps to reproduce
1. Active Directory 2012R2 and accessed trough LDAP, owncloud users on "owncloud-group"
2. users on OU=ou-name,dc=domain,dc=it and added on "owncloud-group" ok
3. users on OU=ou-name,OU=ou-name,OU=ou-name,dc=domain,dc=it and added on "owncloud-group" are not listed and the test on LDAP form do not enumerate

Expected behaviour
all users added on owncloud-group must be a owncloud user.
(|(|(memberof=CN=owncloud-group,OU=ou-name,OU=ou-name,DC=domain,DC=it)(primaryGroupID=11657)))

Actual behaviour
only users on OU of point 2 are listed

Server configuration
Operating system: UBUNTU 16.04 - LAMP
Web server: Apache/2.4.18 (Ubuntu)
Database: Ver 14.14 Distrib 5.7.13
PHP version: 7.0.8
ownCloud version (see ownCloud admin page): 9.1.0.15
Updated from an older ownCloud or fresh install: fresh install using repository ubuntu
ownCloud log (data/owncloud.log, see https://central.owncloud.org/t/how-to-find-webserver-or-oc-logfile-enable-php-logfile/808): empty

Special configuration (external storage, external authentication, reverse proxy, server-side-encryption):
only external authentication

Integrity status for oC9+

Login as admin user into your ownCloud and access
http://example.com/index.php/settings/integrity/failed
paste the results here.
RESULT:
No errors have been found.