Libre office integration problem and two factorAuth

help

#1

I have installed owncloud 9.1 on centos 7.1.
Can't integrate libre office and in terminal works ok
libreoffice --headless --nologo --nofirststartwizard --invisible --norestore --convert-to pdf --outdir /home example.odt
path in config.php is set

Also have log full of lines for two factor auth and don't have app installed for that.

{"reqId":"","remoteAddr":"123.123.123.123","app":"PHP","message":"Undefined index: two-factor-providers at \/var\/www\/owncloud\/lib\/private\/Authentication\/TwoFactorAuth\/Manager.php#111","level":3,"time":"2016-09-16T11:17:27+00:00","method":"GET","url":"\/owncloud\/index.php\/settings\/apps\/categories","user":"user"}
{"reqId":"","remoteAddr":"123.123.123.123","app":"PHP","message":"Invalid argument supplied for foreach() at \/var\/www\/owncloud\/lib\/private\/Authentication\/TwoFactorAuth\/Manager.php#112","level":3,"time":"2016-09-16T11:17:27+00:00","method":"GET","url":"\/owncloud\/index.php\/settings\/apps\/categories","user":"user"}

remoteAddr":"123.123.123.123","app":"documents","message":"Conversion test failed. Raw output:sh: \/usr\/lib64\/libreoffice: Is a directory\n","level":2,"time":"2016-09-16T12:48:47+00:00","method":"POST","url":"\/owncloud\/index.php\/apps\/documents\/ajax\/admin.php","user":"user"}


#2

Hi,

the issue is not related to 2FA but to a wrong configured path in your config.php:

You're redirecting ownCloud to a folder which doesn't work as ownCloud needs the path to the libreoffice binary.


#3

this is what I have in config.php and path is correct
'preview_libreoffice_path' => '/usr/lib64/libreoffice',

Do you also have any idea about two factor error, what cause that?


#4

The posted logfile is showing the opposite and is coming directly from your system. This message doesn't lie.

Report this directly to the developers at https://github.com/owncloud/core/issues (after you have used the search for that error there).

For the future please also avoid mixing two different issues in one thread for the reasons explained here:


#5

Thank you in future will open 2 threads.

In log is path the same as I have in config
/usr/lib64/libreoffice


#6

Yes, and this is wrong as you're pointing the config entry to a directory and not to the actual "libreoffice" binary.


#7

Thank you for hint now it works I changed path to
'preview_libreoffice_path' => '/usr/lib64/libreoffice/program/soffice',