Local cache not working (apcu or redis)

redis
10

#1

Steps to reproduce

  1. Configure owncloud to use local cache reading the official documentation
  2. Try APCu (I installed php-apcu)
  3. Try Redis (I installed php-redis and redis-server)

Expected behaviour

Owncloud using apcu/redis as caching methode

Actual behaviour

Error message saying that the php module is missing or not enabled

apcu and redis php modules are enabled. Redis is configured as cache too with unix socket. both extentions config use the same name.so as official doc here. Redis is running and the sock is in place. Both version are superior as the version requested.

Server configuration

Operating system: Ubuntu 17.10 (I know you're not compatible for it but I've the same error on 17.4 just before dist-upgrade)

Web server: Apache/2.4.27

Database: mysql Ver 14.14 Distrib 5.7.21

PHP version: PHP 7.1.11

ownCloud version: 10.0.5.4

Updated from an older ownCloud or fresh install: Updated from 9.something (don't remimber which version)

Where did you install ownCloud from: Official repo for Ubuntu from owncloud docs

Signing status (ownCloud 9.0 and above): Memcache \OC\Memcache\Redis not available for local cache Is the matching PHP module installed and enabled?

The content of config/config.php:

{
    "system": {
        "passwordsalt": "***REMOVED SENSITIVE VALUE***",
        "secret": "***REMOVED SENSITIVE VALUE***",
        "trusted_domains": [
            "***REMOVED SENSITIVE VALUE***",
            "***REMOVED SENSITIVE VALUE***"
        ],
        "forcessl": true,
        "instanceid": "oc7bd28573e8",
        "datadirectory": "\/var\/www\/owncloud\/data",
        "overwrite.cli.url": "***REMOVED SENSITIVE VALUE***",
        "dbtype": "mysql",
        "version": "10.0.5.4",
        "dbname": "owncloud",
        "dbhost": "localhost",
        "dbtableprefix": "oc_",
        "dbuser": "***REMOVED SENSITIVE VALUE***",
        "dbpassword": "***REMOVED SENSITIVE VALUE***",
        "installed": true,
        "mail_from_address": "***REMOVED SENSITIVE VALUE***",
        "mail_smtpmode": "php",
        "mail_domain": "***REMOVED SENSITIVE VALUE***",
        "maintenance": false,
        "loglevel": "2",
        "memcache.local": "\\OC\\Memcache\\Redis",
        "memcache.locking": "\\OC\\Memcache\\Redis",
        "redis": {
            "host": "/var/run/redis/redis.sock",
            "port": 0
        },
        "enable_previews": true,
        "updatechecker": false,
        "theme": ""
    }
}

List of activated apps:

Enabled:
  - activity: 2.3.6
  - announcementcenter: 1.2.0
  - audioplayer: 2.2.4
  - comments: 0.3.0
  - configreport: 0.1.1
  - dav: 0.3.2
  - encryption: 1.3.1
  - federatedfilesharing: 0.3.1
  - files: 1.5.1
  - files_external: 0.7.1
  - files_pdfviewer: 0.8.2
  - files_sharing: 0.10.1
  - files_texteditor: 2.2.1
  - files_trashbin: 0.9.1
  - files_versions: 1.3.0
  - files_videoplayer: 0.9.8
  - firstrunwizard: 1.1
  - gallery: 16.0.2
  - market: 0.2.3
  - notifications: 0.3.2
  - polls: 0.8.0
  - provisioning_api: 0.5.0
  - security: 0.0.2
  - systemtags: 0.3.0
  - templateeditor: 0.2
  - updatenotification: 0.2.1
Disabled:
  - external
  - federation
  - theme-example
  - user_external

Are you using external storage, if yes which one: NO

Are you using encryption: yes

Are you using an external user-backend, if yes which one: Not as I know

Client configuration

Browser: Chrome Version 63.0.3239.108

Operating system: Fedora 27

Logs

Web server error log

NO - ERROR

ownCloud log (data/owncloud.log)

{"reqId":"QVq2hXXiqBNv2k3jVxat","level":3,"time":"2018-01-25T12:50:53+00:00","remoteAddr":"127.0.0.1","user":"--","app":"core","method":"GET","url":"\/owncloud\/index.php\/settings\/integrity\/failed","message":"Memcache \\OC\\Memcache\\Redis not available for local cache Is the matching PHP module installed and enabled?"}
{"reqId":"QVq2hXXiqBNv2k3jVxat","level":3,"time":"2018-01-25T12:50:53+00:00","remoteAddr":"127.0.0.1","user":"--","app":"core","method":"GET","url":"\/owncloud\/index.php\/settings\/integrity\/failed","message":"Exception: {\"Exception\":\"OC\\\\HintException\",\"Message\":\"Memcache \\\\OC\\\\Memcache\\\\Redis not available for local cache\",\"Code\":0,\"Trace\":\"#0 \\\/home\\\/www\\\/owncloud\\\/lib\\\/private\\\/Server.php(410): OC\\\\Memcache\\\\Factory->__construct('0376c8c707dea67...', Object(OC\\\\Log), '\\\\\\\\OC\\\\\\\\Memcache\\\\\\\\Re...', '\\\\\\\\OC\\\\\\\\Memcache\\\\\\\\Re...', '\\\\\\\\OC\\\\\\\\Memcache\\\\\\\\Re...')\\n#1 \\\/home\\\/www\\\/owncloud\\\/lib\\\/composer\\\/pimple\\\/pimple\\\/src\\\/Pimple\\\/Container.php(113): OC\\\\Server->OC\\\\{closure}(Object(OC\\\\Server))\\n#2 \\\/home\\\/www\\\/owncloud\\\/lib\\\/private\\\/AppFramework\\\/Utility\\\/SimpleContainer.php(111): Pimple\\\\Container->offsetGet('MemCacheFactory')\\n#3 \\\/home\\\/www\\\/owncloud\\\/lib\\\/private\\\/ServerContainer.php(87): OC\\\\AppFramework\\\\Utility\\\\SimpleContainer->query('MemCacheFactory')\\n#4 \\\/home\\\/www\\\/owncloud\\\/lib\\\/private\\\/Server.php(1141): OC\\\\ServerContainer->query('MemCacheFactory')\\n#5 \\\/home\\\/www\\\/owncloud\\\/lib\\\/private\\\/Server.php(557): OC\\\\Server->getMemCacheFactory()\\n#6 \\\/home\\\/www\\\/owncloud\\\/lib\\\/composer\\\/pimple\\\/pimple\\\/src\\\/Pimple\\\/Container.php(113): OC\\\\Server->OC\\\\{closure}(Object(OC\\\\Server))\\n#7 \\\/home\\\/www\\\/owncloud\\\/lib\\\/private\\\/AppFramework\\\/Utility\\\/SimpleContainer.php(111): Pimple\\\\Container->offsetGet('AppManager')\\n#8 \\\/home\\\/www\\\/owncloud\\\/lib\\\/private\\\/ServerContainer.php(87): OC\\\\AppFramework\\\\Utility\\\\SimpleContainer->query('AppManager')\\n#9 \\\/home\\\/www\\\/owncloud\\\/lib\\\/private\\\/Server.php(1359): OC\\\\ServerContainer->query('AppManager')\\n#10 \\\/home\\\/www\\\/owncloud\\\/lib\\\/private\\\/legacy\\\/app.php(566): OC\\\\Server->getAppManager()\\n#11 \\\/home\\\/www\\\/owncloud\\\/lib\\\/private\\\/L10N\\\/Factory.php(313): OC_App::getAppPath('search')\\n#12 \\\/home\\\/www\\\/owncloud\\\/lib\\\/private\\\/L10N\\\/Factory.php(191): OC\\\\L10N\\\\Factory->findL10nDir('search')\\n#13 \\\/home\\\/www\\\/owncloud\\\/lib\\\/private\\\/L10N\\\/Factory.php(227): OC\\\\L10N\\\\Factory->findAvailableLanguages('search')\\n#14 \\\/home\\\/www\\\/owncloud\\\/lib\\\/private\\\/L10N\\\/Factory.php(165): OC\\\\L10N\\\\Factory->setLanguageFromRequest('search')\\n#15 \\\/home\\\/www\\\/owncloud\\\/lib\\\/private\\\/legacy\\\/util.php(581): OC\\\\L10N\\\\Factory->findLanguage('search')\\n#16 \\\/home\\\/www\\\/owncloud\\\/lib\\\/private\\\/legacy\\\/util.php(554): OC_Util::addTranslations('search')\\n#17 \\\/home\\\/www\\\/owncloud\\\/lib\\\/private\\\/legacy\\\/template.php(139): OC_Util::addScript('search', 'search', true)\\n#18 \\\/home\\\/www\\\/owncloud\\\/lib\\\/private\\\/legacy\\\/template.php(81): OC_Template::initTemplateEngine('error')\\n#19 \\\/home\\\/www\\\/owncloud\\\/lib\\\/private\\\/legacy\\\/template.php(332): OC_Template->__construct('', 'error', 'error', false)\\n#20 \\\/home\\\/www\\\/owncloud\\\/index.php(65): OC_Template::printErrorPage('Memcache \\\\\\\\OC\\\\\\\\Me...', 'Is the matching...')\\n#21 {main}\",\"File\":\"\\\/home\\\/www\\\/owncloud\\\/lib\\\/private\\\/Memcache\\\/Factory.php\",\"Line\":95}"}

Browser log

Request URL:https://**********************/owncloud/index.php/settings/integrity/failed
Request Method:GET
Status Code:500 Internal Server Error
Remote Address:**********************:443
Referrer Policy:no-referrer-when-downgrade

#2

Hi,

can you post here what commands you used to install the modules?

The ones for Redis and APCu

also your config.php would be interesting


#3

config.php is already in my first post :wink:

sudo apt install php-apcu php-redis redis-server.
And I used phpenmod too for both.
In the phpinfo print I can see that both are enabled so I don't know why OC don't detect it.