Login fails without error


#1

<!--

Steps to reproduce

  1. Setup Owncloud
  2. Try to login with different browsers
  3. On some / sometimes, nothing happens

Expected behaviour

User with correct credentials should login

Actual behaviour

There is no error message shown, no log entries appear in the server log (access.log/error.log) for the login attempt. After disabling the file share app, the problem was gone. The problem was described in the old forum in posts of 2016 (!!!).

Server configuration

Debian Jessie

Apache

Maria DB

PHP 7.0

10.0.6.1

Updated 10.0.4 and earlier

Owncloud website

Failed due to web management files (error and stat files)

Enabled:
- activity: 2.3.6
- calendar: 1.5.4
- comments: 0.3.0
- configreport: 0.1.1
- contacts: 1.5.3
- dav: 0.3.2
- federatedfilesharing: 0.3.1
- federation: 0.1.0
- files: 1.5.1
- files_antivirus: 0.11.2
- files_external: 0.7.1
- files_pdfviewer: 0.8.2
- files_texteditor: 2.2.1
- files_trashbin: 0.9.1
- files_versions: 1.3.0
- files_videoplayer: 0.9.8
- firstrunwizard: 1.1
- gallery: 16.0.2
- market: 0.2.3
- notifications: 0.3.2
- provisioning_api: 0.5.0
- systemtags: 0.3.0
- templateeditor: 0.2
- updatenotification: 0.2.1
Disabled:
- encryption
- external
- files_sharing
- theme-example
- user_external

No external storage

No encryption

external auth: IMAP

Client configuration

Different (Chrome, IE, Edge, Firefox, both PC and Android)


#2

Hi, you don't have the link to the problem description in the old forum by chance?


#3

Here we go

https://forum.owncloud.org/viewtopic.php?t=33082

Second last posts describes that it worked (like for me) after disabling the shared files plugin.


#4

Great. I guess you have tried to solution given by realrancor?


#5

@dmitry

The answer there did not help so far. The tmp folder for that subdomain has 0x777 access rights. Disabling the share files app solved the problem but that is not a 3rd party app.

The problem is random, sometimes it occurs with one browser, sometimes with another... as it was reported in 2016, I hoped it would be solved meanwhile.


#6

Would you like for me to open an issue on github?


#7

No problem, in what area, core owncloud or the file share app?


#8

It was not solved by the share files plugin, it happens also without... but

Refused to execute inline script because it violates the following Content Security Policy directive: "script-src 'self' 'unsafe-eval'". Either the 'unsafe-inline' keyword, a hash ('sha256-udW+vvPU6ZphBfIB8EgfQ/8N6tG3MMEZ5Xr/T2R2G90='), or a nonce ('nonce-...') is required to enable inline execution.

there seems to be a reason, Chrome Java log.

Github issue created.