Login impossible because of update-info

help

#1

System says: Owncloud will be updated to 8.2.1
If I click on update - then it says: Updates between multiple major versions and downgrades are unsupported.

Now how can I login into my current account, when there comes always this message up?
My Version is 6.0.41
(no complaints about this old version please, thats not helpful, thanks.)


#2

Hi,

please see:

which should show up in the search if you search for "Updates between multiple major versions and downgrades are unsupported." here at the forums.


#3

Funny. I am able to use google, thanks.

My question was: How do I login, which shows up, if you read my posting.

Also no remote function works, like for example: www.server.de/owncloud/remote.php
in effect, that my external address-book, which I was trying to sync, now is empty. (Message: Service unavailable)

Plus, if I eventually wanted to update - your quoted thread does no explain how to update from 6.xxx to 8.xxx
But, I do not want to update, I want to LOGIN (and use the installed system).


#4

Hi,

you already have done an upgrade of the ownCloud code so you can't login in the current state. So why did you do an upgrade if you don't want to actually upgrade?

This is aboslutely wrong. The quoted thread exactly explains how to upgrade and shows detailed steps with an example upgrade path from 8.0.x to 8.2.x. Sure, it doesn't exactly provides each step between 6.x to 8.x but people should be at least able to read simple instructions and apply them to their current environment by replacing some version numbers.


#5

I tried to update because the software offered me this. And after beginning, after making the installation completely unusable, the software tells me, major-version-update is not supported? Then why does it start at all??? Too hard to have one single look into config.php ? The software leaves me alone with a broken installation, where it could have known better.

As stated before: NOW I do not want to update (any more).

Ok, back to my question: Login not possible, you say? Back-draw not possible? From which version do I have to update now? 6.xxx in database and 8.xxx in Code??? And you say, this is explained in the quoted thread, just by replacing some version numbers?


#6

Because you didn't catched up with updates and used such an outdated version like 6.0.4 which was released more then two years ago... Recent oC versions are doing a correct upgrade without showing such an issue.

Yes:

As the message is telling you, you have done an unsupported upgrade path. For example:

Original version: 8.0.2
Upgraded version: 8.2.6

In this case you have skipped the 8.1.x major upgrade which is unsupported as stated within the documentation.

Solution:

  • Remove all files and folders of your oC installation folder except /data/ and /config/
  • Download 8.0.13 from https://owncloud.org/changelog/
  • Extract the content of the archive it into your oC installation folder
  • Run the update via the webgui or the occ command line tool.

Afterwards repeat those steps with 8.1.8 and 8.2.6

and as it seems you can't map this instructions to your environment the matching one for your upgrade path:

In this case you have skipped several major upgrades which is unsupported as stated within the documentation.

Solution:

  • Remove all files and folders of your oC installation folder except /data/ and /config/
  • Download 6.0.9 from https://owncloud.org/changelog/
  • Extract the content of the archive it into your oC installation folder
  • Run the update via the webgui or the occ command line tool.

Afterwards repeat those steps with 7.0.15, 8.0.14, 8.1.9, 8.2.6 and 9.0.4 (i wouldn't go for 9.1.0 for now).

This is the only sane way to get a login back. If you still struggling with this instructions there are additional documentation available here:

https://doc.owncloud.org/server/9.0/admin_manual/maintenance/manual_upgrade.html


#7

Sure?? Really sure?
New software - new errors...

No.
It startet, because it did not check pre-requesites at the beginning.

Now I am setting up a fresh 9.1 and new questions come up - thats the reason, why I do not update, if not necessary. For example: My own code does not work any more with 9, which it did with version 6.
Never change a running system...

PS: I also still use Win-XP - why? Why not. It works, thats all, I want.

Do you buy a new vacuum cleaner every year?
Of course not. But in software business, you expect users to do...

Thread can be closed. No more questions here from me.


#8

#9

New software - new errors...

Old software, old errors which are already fixed in new versions. And no, still running Windows XP because its "just working" is no excuse and no reason to stay with it. Nothing more to say here...