i have a “standard” owncloud installation. If a user forgot his password, he can click on reset password. But nothing happen. He does not get an email. I tried with some users (correct email address was saved for the users).

In the config.php i see

‘lost_password_link’ => ‘true’

Must this be changed ? I didn’t connect an external LDAP.

Thx for any information.


Hi hoko,

there was an issue template when you started this topic. This is there for the good reason, that without further information we cannot even guess what is failing on your system.
Especially owncloud.log and Server configuration are absolutely necessary.

For your convenience, here is the issue template again:

Steps to reproduce

Expected behaviour

Tell us what should happen

Actual behaviour

Tell us what happens instead

Server configuration

Operating system:

Web server:


PHP version:

ownCloud version: (see ownCloud admin page)

Updated from an older ownCloud or fresh install:

Where did you install ownCloud from:

Signing status (ownCloud 9.0 and above):

Login as admin user into your ownCloud and access 
paste the results into https://gist.github.com/ and puth the link here.

The content of config/config.php:

Log in to the web-UI with an administrator account and click on
'admin' -> 'Generate Config Report' -> 'Download ownCloud config report'
This report includes the config.php settings, the list of activated apps
and other details in a well sanitized form.


If you have access to your command line run e.g.:
sudo -u www-data php occ config:list system
from within your ownCloud installation folder

*ATTENTION:* Do not post your config.php file in public as is. Please use one of the above
methods whenever possible. Both, the generated reports from the web-ui and from occ config:list
consistently remove sensitive data. You still may want to review the report before sending.
If done manually then it is critical for your own privacy to dilligently
remove *all* host names, passwords, usernames, salts and other credentials before posting.
You should assume that attackers find such information and will use them against your systems.

List of activated apps:

If you have access to your command line run e.g.:
sudo -u www-data php occ app:list
from within your ownCloud installation folder.

Are you using external storage, if yes which one: local/smb/sftp/…

Are you using encryption: yes/no

Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/…

LDAP configuration (delete this part if not used)

With access to your command line run e.g.:
sudo -u www-data php occ ldap:show-config
from within your ownCloud installation folder

Without access to your command line download the data/owncloud.db to your local
computer or access your SQL server remotely and run the select query:
SELECT * FROM `oc_appconfig` WHERE `appid` = 'user_ldap';

Eventually replace sensitive data as the name/IP-address of your LDAP server or groups.

Client configuration


Operating system:


Web server error log

Insert your webserver log here

ownCloud log (data/owncloud.log)

Insert your ownCloud log here

Browser log

Insert your browser log here, this could for example include:

a) The javascript console log
b) The network log 
c) ...

config_report_20200720.txt (315.1 KB) owncloud.txt (1.9 MB)

In your configreport it shows that lost_password_link is set to false

Please read the documentation about this parameter:


1 Like

now i set it to true, but still nothing happens…

config_report_20200720-01.txt (315.7 KB)


delete the line with lost_password_link from your config.php and try again.

Referring to the docs you can read, that this configuration option is there to provide password changes when passwords are handled outside of ownCloud, e.g. with LDAP: https://doc.owncloud.com/server/admin_manual/configuration/server/config_sample_php_parameters.html#code-sample-30

In you configreport I see you have the user_ldap app enabled. Users who come from that backend cannot have their passwords changed with the default functionality.


Hi Cortho,

deleting the line “lost_password_link” solved my problem. Thank you.

Best Regards