Market update from version 0.2.2 to version 0.2.3 not successful

marketplace
update

#1

Hi!
When I'm trying to upgrade, it's saying "App market updated successfully" but nothing is done ...

There is always the notification (because it didn't update).

What can I do ?


Market update fails from version 0.2.2 to version 0.2.3
#2

Most likely the apps folder it not writable by owncloud. Please change the ownership of the folder to your web server user


#3

Had the same problem. I changed the write permissions of the "apps" folder and all subfolders(!) and it worked.


#4

Thank you both of you, it worked (and I feel dumb not to have thought about it).

Have a nice day !


#5

There are no dumb question - just dump answers!
Happy to hear it works for you now!


#6

Can you tell what permissions you gave where?!
The same problem I have with the antivirus app fails?!


#7

I used a little script I took somewhere (don't remember where sorry).

Here it is :

!/bin/bash

ocpath='/var/www/owncloud'
htuser='www-data'
htgroup='www-data'
rootuser='root'

printf "Creating possible missing Directories\n"
mkdir -p $ocpath/data
mkdir -p $ocpath/assets
mkdir -p $ocpath/updater

printf "chmod Files and Directories\n"
find ${ocpath}/ -type f -print0 | xargs -0 chmod 0640
find ${ocpath}/ -type d -print0 | xargs -0 chmod 0750

printf "chown Directories\n"
chown -R ${rootuser}:${htgroup} ${ocpath}/
chown -R ${htuser}:${htgroup} ${ocpath}/apps/
chown -R ${htuser}:${htgroup} ${ocpath}/assets/
chown -R ${htuser}:${htgroup} ${ocpath}/config/
chown -R ${htuser}:${htgroup} ${ocpath}/data/
chown -R ${htuser}:${htgroup} ${ocpath}/themes/
chown -R ${htuser}:${htgroup} ${ocpath}/updater/

chmod +x ${ocpath}/occ

printf "chmod/chown .htaccess\n"
if [ -f ${ocpath}/.htaccess ]
then
chmod 0644 ${ocpath}/.htaccess
chown ${rootuser}:${htgroup} ${ocpath}/.htaccess
fi
if [ -f ${ocpath}/data/.htaccess ]
then
chmod 0644 ${ocpath}/data/.htaccess
chown ${rootuser}:${htgroup} ${ocpath}/data/.htaccess
fi


#8

As I am in a local testing environment I set all permissions recursively to 777 which is not the best idea for production environments.
The scripts looks fine on the first look. Maybe just try it?


#9

The script is not working. I can't update market and antivirus app. If you change rights you need to understand what to do, otherwise you loose system security. Why is there no help by community, becauser there are many have this problem.


#10

If you ask me i see more then enough help from the community in this thread, especially this post is something which should fit and solve this issue: https://central.owncloud.org/t/market-update-from-version-0-2-2-to-version-0-2-3-not-successful/10425/3