Market will not load, loading icon just spins


#1

Steps to reproduce

  1. Upgrade from 9.0.0 to 9.1 to 10.0.2.1.
  2. Try to load the Market index.php/apps/market/#/

Expected behaviour

The market should load.

Actual behaviour

The loading icon just spins.

Server configuration

Operating system:
Ubuntu 14.04

Web server:
Apache 2.4
Database:
Mysql 5.6
PHP version:
7.1
ownCloud version: (see ownCloud admin page)
10.0.2.1
Updated from an older ownCloud or fresh install:
Updated from 9.0.0 to 9.1 to 10.

Where did you install ownCloud from:
Original 9.0 was from git. Upgraded to 9.1 and 10 tarballs.

Signing status (ownCloud 9.0 and above):

No errors have been found.

The content of config/config.php:

{
    "system": {
        "installed": true,
        "dbtype": "mysql",
        "dbname": "owncloud",
        "dbuser": "***REMOVED SENSITIVE VALUE***",
        "dbpassword": "***REMOVED SENSITIVE VALUE***",
        "dbhost": "dbhostip",
        "dbtableprefix": "oc_",
        "passwordsalt": "***REMOVED SENSITIVE VALUE***",
        "forcessl": true,
        "blacklisted_files": [],
        "overwritehost": "",
        "overwriteprotocol": "",
        "overwritewebroot": "",
        "overwritecondaddr": "",
        "theme": "lane",
        "default_language": "en",
        "3rdpartyroot": "",
        "3rdpartyurl": "",
        "defaultapp": "files",
        "knowledgebaseenabled": true,
        "knowledgebaseurl": "http:\/\/api.apps.owncloud.com\/v1",
        "appstoreurl": "http:\/\/api.apps.owncloud.com\/v1",
        "mail_smtpdebug": false,
        "mail_smtpmode": "php",
        "mail_smtphost": "127.0.0.1",
        "mail_smtpport": "25",
        "mail_smtptimeout": 10,
        "mail_smtpauthtype": "LOGIN",
        "trashbin_retention_obligation": "180, auto",
        "allow_user_to_change_display_name": true,
        "appcodechecker": "",
        "updatechecker": true,
        "log_type": "syslog",
        "logfile": "",
        "loglevel": 0,
        "remember_login_cookie_lifetime": 1296000,
        "session_lifetime": 86400,
        "custom_csp_policy": "default-src 'self'; script-src 'self' 'unsafe-eval'; style-src 'self' 'unsafe-inline'; frame-src *; img-src *; font-src 'self' data:; media-src *",
        "xframe_restriction": true,
        "datadirectory": "\/path\/to\/data\/test",
        "maintenance": false,
        "apps_paths": [
            {
                "path": "\/var\/www\/owncloud\/apps",
                "url": "\/apps",
                "writable": true
            }
        ],
        "customclient_desktop": "http:\/\/owncloud.org\/sync-clients\/",
        "customclient_android": "https:\/\/play.google.com\/store\/apps\/details?id=com.owncloud.android",
        "customclient_ios": "https:\/\/itunes.apple.com\/us\/app\/owncloud\/id543672169?mt=8",
        "logdateformat": "F d, Y H:i:s",
        "instanceid": "525f0e87378ff",
        "version": "10.0.2.1",
        "ldapIgnoreNamingRules": false,
        "trusted_domains": [
            "testowncloud.lanecc.edu"
        ],
        "secret": "***REMOVED SENSITIVE VALUE***",
        "memcache.local": "\\OC\\Memcache\\Redis",
        "redis": {
            "host": "localhost",
            "port": 6379,
            "timeout": 0
        },
        "filelocking.enabled": "true",
        "memcache.locking": "\\OC\\Memcache\\Redis"
    }
}

List of activated apps:

Enabled:
  - comments: 0.3.0
  - configreport: 0.1.1
  - dav: 0.2.9
  - federatedfilesharing: 0.3.0
  - federation: 0.1.0
  - files: 1.5.1
  - files_external: 0.7.0
  - files_pdfviewer: 0.8.2
  - files_sharing: 0.10.0
  - files_texteditor: 2.2
  - files_trashbin: 0.9.0
  - files_versions: 1.3.0
  - files_videoplayer: 0.9.8
  - firstrunwizard: 1.1
  - gallery: 16.0.2
  - market: 0.1.0
  - notifications: 0.3.0
  - provisioning_api: 0.5.0
  - systemtags: 0.3.0
  - templateeditor: 0.1
  - updatenotification: 0.2.1
  - user_ldap: 0.9.1
Disabled:
  - encryption
  - external
  - files_antivirus
  - theme-example
  - user_external

Are you using external storage, if yes which one: local/smb/sftp/...
No
Are you using encryption: yes/no
No
Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/...
LDAP, Novell eDirectory

LDAP configuration (delete this part if not used)

N/A

Client configuration

Browser:
Firefox
Operating system:
Ubuntu 16.04

Logs

Web server error log

N/A

ownCloud log (data/owncloud.log)

Aug 31 11:19:04 testowncloud ownCloud[25901]: {PHP} array_map(): Argument #2 should be an array at /var/www/owncloud/apps/market/lib/Controller/MarketController.php#165

OC 10 and Marketplace
#2

I see a lot of non-default stuff in your config.php, especially the appstoreurl shouldn't be in there in a default config.


OC 10 and Marketplace
#3

I have been upgrading this instance since OwnCloud 5.x or so....

I will compare with the example config.php file soon. Thanks for the tip.


#4

Ok, I cleaned out my config.php. I took a look at config.sample.php and confirmed that anything I had set in config.php was an option in config.sample.php.

The issue still occurs.

I still get the array_map error in syslog.

Sep  7 12:39:07 web-test-host-01 ownCloud[27041]: {PHP} array_map(): Argument #2 should be an array at /var/www/owncloud/apps/market/lib/Controller/MarketController.php#165

Checking the config with sudo -u www-data php occ config:list system gives:

{
    "system": {
        "installed": true,
        "dbtype": "mysql",
        "dbname": "owncloud",
        "dbuser": "***REMOVED SENSITIVE VALUE***",
        "dbpassword": "***REMOVED SENSITIVE VALUE***",
        "dbhost": "dbhost",
        "dbtableprefix": "oc_",
        "passwordsalt": "***REMOVED SENSITIVE VALUE***",
        "blacklisted_files": [],
        "theme": "lane",
        "default_language": "en",
        "defaultapp": "files",
        "knowledgebaseenabled": true,
        "mail_smtpdebug": false,
        "mail_smtpmode": "php",
        "mail_smtphost": "mailhost.blah.fff",
        "mail_smtpport": "25",
        "mail_smtpsecure": "tls",
        "mail_smtptimeout": 10,
        "mail_smtpauthtype": "LOGIN",
        "mail_smtpauth": true,
        "mail_smtpname": "***REMOVED SENSITIVE VALUE***",
        "mail_smtppassword": "***REMOVED SENSITIVE VALUE***",
        "trashbin_retention_obligation": "180, auto",
        "allow_user_to_change_display_name": true,
        "updatechecker": true,
        "log_type": "syslog",
        "loglevel": 0,
        "logfile": "\/var\/log\/owncloud.log",
        "remember_login_cookie_lifetime": 1296000,
        "session_lifetime": 86400,
        "datadirectory": "\/path\/to\/data\/test",
        "maintenance": false,
        "apps_paths": [
            {
                "path": "\/var\/www\/owncloud\/apps",
                "url": "\/apps",
                "writable": true
            }
        ],
        "customclient_desktop": "https:\/\/owncloud.org\/install\/#install-clients",
        "customclient_android": "https:\/\/play.google.com\/store\/apps\/details?id=com.owncloud.android",
        "customclient_ios": "https:\/\/itunes.apple.com\/us\/app\/owncloud\/id543672169?mt=8",
        "logdateformat": "F d, Y H:i:s",
        "instanceid": "525f0e87378ff",
        "version": "10.0.2.1",
        "trusted_domains": [
            "hostname.example.org",
            "web-test-host-01.example.org"
        ],
        "secret": "***REMOVED SENSITIVE VALUE***",
        "memcache.local": "\\OC\\Memcache\\Redis",
        "redis": {
            "host": "localhost",
            "port": 6379,
            "timeout": 0
        },
        "filelocking.enabled": true,
        "memcache.locking": "\\OC\\Memcache\\Redis"
    }
}

#5

I see the market app uses the cache, so you can try to clean the cache and see what happens.


#6

Wow. I thought for sure I had tried clearing the browser's cache already... Sheesh. You'd think I'd remember that step after finding it solved the problem dozens of times in the past....

Thanks @jvillafanez!


#7

I was refering to the redis cache, but if it's solved then it's ok


#8

How would you clear the redis cache? Wouldn't a system restart do it? 'Cause I had done that a couple times when upgrading OS packages.


#9

Probably, but maybe there are persistence options active in redis that could bring the into memory when the server is restarted. You might want to check that options just in case.