Marketplace does not load

OC Version 10.8
Market App Version 0.6.1

Lately the app does not open, the loading circle turns and after some time at the bottom right hand side comes:

No marketplace connection: cURL error 28. Failed to connect to marketplace.owncloud.com port 443 after 75274ms: connection timed out.

It shows that 1 update is open but it will not show which app is to update.

By trying to enter an API-key into the app I always get: The API-key is invalid.

Connection to marketplace.owncloud.com with the browser works perfect.

On the basis of this updating OC to 10.9 is not possible since the update wants to update Webdav and cant connect and stops with an error.

Any suggestion ?

Hello, that could be related to: Owncloud Upgrade 10.8 to 10.9 Error 403 marketplace.owncloud.com - #9 by micbar

We have created a version of the Market app that we will also ship with the new server version 10.9.1. There were problems with a NULL value in the database.

Can you update your app via the CLI?
occ market:upgrade market

1 Like

Can you update your app via the CLI?
occ market:upgrade market

Unfortunately not.

The user is still on 10.8, so I think it is not related as the issue you’re linking is only occurring after the upgrade to 10.9

Can you try to just curl -I https://marketplace.owncloud.com on the command line of your ownCloud server?

The timeout on the outgoing connection to SSL is something very curious. Perhaps you have an outgoing firewall set? Can you connect to something else, let’s say google.com, on HTTPS?

Where do you enter it, and when exactly are receiving this message? How did you create the API key?

By the way, there are known issues for 10.9 and if you are using encryption you should wait for 10.9.1

1 Like

I got my Server host to try this command and he could not connect. He assumes that my IP’s might be blocked on the marketplace server and I should check.
But I dont know where to turn to to get this checked.

If I call marketplace there is an option, on the left side of the screen, to enter the API key, this one I tried to use.
The key I got from the marketplace website where I registered

You can’t get this checked, I will try to find out for you. I’ll let you know.


EDIT:
Update: currently there are no blocked IP addresses on the marketplace side.

I would recommend to remove the current API key from your ownCloud configuration before retrying whether it works now.

If it still doesn’t, I would check what this is resolving to, try pinging it. And double/triple checking that there is no outgoing firewall or proxy enabled, that is blocking the requests.

This is definitely the source of your issue and needs to be resolved. As I am not aware of any other users/servers having issues connecting to marketplace it is most likely a problem with either the VM your ownCloud is running on or the network of the hoster.

Thanks for your efforts @eneubauer

My host was able to run the update successful from his side since he has CLI access. After this I could enter the marketplace API-key and now marketplace behaves as it should.

1 Like