Message Logs Incorrect Timestamp


#1

Hi, This is my first post!

When our OwnCloud users receive an activity email, it shows the timestamp -1 hour behind local time. All users are in Berlin, and have correct local time on their computers.

However, the linux server timedatectl command produces the following output, none of which indicates a -1 hour differential:

  Local time: Mon 2018-06-04 16:20:18 CEST

Universal time: Mon 2018-06-04 14:20:18 UTC
RTC time: Mon 2018-06-04 14:20:17
Time zone: Europe/Berlin (CEST, +0200)
Network time on: yes
NTP synchronized: yes
RTC in local TZ: no

Any help most appreciated!


#2

Hey,

from what i know ownCloud is only sending e-mail once an hour (at max.), configurable up to weekly in your personal backend via the “Send emails:” dropdown menue. I think this could explain the one hour difference of the timestamp (when the mail was created) and the time the user is receiving it.


#3

Hey! Thanks for replying!

I did not explain very well, sorry. The email shows all activities with an incorrect timestamp.

If I sent a linkat 08:34, it reports the action at 07:34.


#4

Hey, shortly after my post i have edited a document at my ownCloud 10.0.8 installation. One hour later i have received a mail with the following content:

  • “remote user” changed test.txt - Today at 17:37:37

and the following sending date:

Mon, 4 Jun 2018 18:50:42 +0200 (CEST)

(Times are in CEST)


#5

Hi,

A user made some activity at 10:31am. The email date stamp of the activitiy is now 2 hours behind… UTC time perhaps?


Am 05.06.18, 11:45 schrieb:
Hallo <user_a>,

You receive this email because the following things happened at https://cloud.xxxxx.com/

* You have shared <filename> with <user_b>  - Today at 08:31:02

#6

We recently fixed a bug where the users timezone was not properly saved in the users’s settings.

Furhtermore there is no possibility in the ui for a user to choose the time zone - we will work on this in the future.

To see what timezone of a user is used (replace admin with the user id you want to know about):
./occ user:setting admin core timezone

As a quick work around you can set the user’s timezone like this:

./occ user:setting admin core timezone --value Europe/Berlin


Email notification wrong timezone owncloud 9.1.6.2 stable
Calendar UI Timezone
#7

Many thanks for the reply and for your support!

Is it possible to run the command for all users? We have a lot, and their usernames are all long random sequences :slight_smile:

I tried ./occ user:setting * core timezone --value Europe/Berlin but of course this isn’t correct syntax!

Maybe I have to add all users to a group, and apply the timezone to the group?


#8

There is no such functionality as of today. Maybe you write a small script using the ./occ user:list command to get the list of all users and then loop through them?


#9

Ack. Many thanks. I will come up with a solution!