Missing PDF files

9.0.x
help

#1

Hello,
First of all, sorry for my English, I'll do my best to keep it clean...
As suggested by the title, I have issues (mainly) with PDF files. It seems to be a common issue, but I can't figure out how to correct it... It is my first time with something near as complicated as setting up an OC myself... I am a novice.
The owncloud is for a small company of 4-5 people who need to access those from different towns most of the time, and we mainly use it to share documents (PDFs, pictures) and for the agenda. We choose not to use Dropbox because we liked the "opensource" solution, and because the shared agenda and contact book is very useful for us. Plus we had a spare web hosting we though we might use for it.

Steps to reproduce
1. a PDF file is uploaded and shared by one of the users of the owncloud. It seems to work well at first, everyone can dowload/open it in the embed reader/open it in the browser client.
2. another user modifies it. (I think, I must admit I am not entirely sure of what they did. They aren't either)
3. it is no longer possible for anyone to download nor open an embed version of it, only the browser client works.

Expected behaviour
I should be able to open whatever I want, since my FTP client and the browser show me the files are OK...

Actual behaviour
Actually I described it earlier (I'm not sure I file this form correctly...)
the exact error in the embeded PDF reader is :

PDF.js v1.1.469 (build: f06aa6a)
Message: Missing PDF "https://www.owncloud.XXmydomainXX.fr/remote.php/webdav/Programme%20automne%202016/11_novembre/Pr%C3%A9sentation%20R%C3%A9pliques%20n%C2%B07.pdf".

Server configuration
Operating system: Windows 10
Web server: OVH
Database: MySQL v5.5
PHP version: 5.6
ownCloud version (see ownCloud admin page): 9.0.1
Updated from an older ownCloud or fresh install: fresh
ownCloud log: Okay this is a HUGE file. Do you need me to paste it entirely ?

Special configuration (external storage, external authentication, reverse proxy, server-side-encryption): Not to my knowledge. I had many issues while installing it, thus I am not sure it is quite regular. I tried with Firefox and Chrome and the results are the same.

Integrity status for oC9+

No errors have been found.

So. This said, my question is : how can I open/download these PDFs ? I thought, maybe, it was because some of them had french caracters in their title (like in the example I gave, ç, é, etc.) so I tried to edit the files name via the client, but the web interface didn't refresh the names... It doesn't refresh anything now... And I still have the same problems...
I would like (very much) a possible solution not to delete the data I already uploaded...

I also have other issues, but one at a time... (files one of the users can't delete after an edit via the client, is it possible that both problems are linked ? I think it is the same user who upload the files that cause problems...)

Thanks in advance, I hope my explanations were clear enough...


#2

Hi,

before reporting any issues with outdated oC versions please update to a recent version first. As 9.1.0 is quite fresh and has a few bugs the latest stable 9.0.4 is recommended.


#3

No response. Consider this as solved. If this still exists in a current version, please create a new topic.


#4