More problems with trusted_domains

hosting

#1

I'm using the latest release 10.0.3, and I'm getting the dreaded untrusted domain message:

You are accessing the server from an untrusted domain.
Please contact your administrator. If you are an administrator of this instance, configure the "trusted_domains" setting in config/config.php. An example configuration is provided in config/config.sample.php.

My setup is that I'm running Ubuntu 17 as a VM in Hyper-V.
I only get his error when I try to access owncloud from the browser running on the host. Other computers on the network are fine, other VMs running on Hyper-V are fine and work. Its just the access from the Host that is giving me problems.

Owncloud/Ubuntu17 is at ip: 10.0.0.186. All of my other computer are on the same subnet (10.0.0.XXX).
Below is the IPCONFIG from the host.

I did try to add 192.168.88.1 and 192.168.245.1 to the trusted_domains in config.php but no luck.

The apache logs show that the request from 10.0.0.241 are coming through but owncloud throws the untrusted domain rejection.

Any suggestions?

Windows IP Configuration

Ethernet adapter vEthernet (Broadcom NetXtreme Gigabit Ethernet - Virtual Switch):

Connection-specific DNS Suffix . :
IPv4 Address. . . . . . . . . . . : 10.0.0.241
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 10.0.0.1

Ethernet adapter NIC1:

Connection-specific DNS Suffix . :
IPv4 Address. . . . . . . . . . . : 192.168.0.2
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 10.0.0.1

Ethernet adapter VMware Network Adapter VMnet1:

Connection-specific DNS Suffix . :
IPv4 Address. . . . . . . . . . . : 192.168.245.1
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . :

Ethernet adapter VMware Network Adapter VMnet8:

Connection-specific DNS Suffix . :
IPv4 Address. . . . . . . . . . . : 192.168.88.1
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . :

Tunnel adapter isatap.{1C05C221-2FD6-408F-9649-66B8D998D5BA}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

Tunnel adapter isatap.{1C92F98B-859E-4D8A-AF60-8AD48CCB4C24}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

Tunnel adapter isatap.{81A2A586-178D-41E3-8D87-AD725831B6E7}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

Tunnel adapter isatap.{D043ABD4-4A7D-4FB5-881E-8B20F57999A0}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :


#2

What i'm currently missing here is the info what trusted_domains setting is currently in place.


#3

Sorry, here it is: As you can see, I tried many combination.

<?php
$CONFIG = array (
'updatechecker' => false,
'instanceid' => 'oc2gbl4sik1q',
'passwordsalt' => 'xXxXxXxX',
'secret' => 'xXxXxXxX',
'trusted_domains' =>
array ( '192.168.88.1','192.168.245.1','192.168.0.2','192.168.xxx.xxx','10.0.0.241','10.0.0.186','10.xxx.xxx.xxx','localhost','127.0.0.1',
),
'datadirectory' => '/media/t430_ownCloud',
'overwrite.cli.url' => 'http://localhost/owncloud',
'dbtype' => 'mysql',
'version' => '10.0.3.3',
'dbname' => 'owncloud',
'dbhost' => 'localhost',
'dbtableprefix' => 'oc_',
'mysql.utf8mb4' => true,
'dbuser' => 'oc_tek',
'dbpassword' => 'xXxXxXxX',
'logtimezone' => 'UTC',
'installed' => true,
);