MultiKeyEncryptException after upgrade to owncloud X

encryption

#1

Hey guys,
since the upgrade to owncloud X (10.0.0) I'm seeing the following error in both the desktop sync client and via occ:

[OCA\Encryption\Exceptions\MultiKeyEncryptException]
multikeyencryption failed error:0906D06C:PEM routines:PEM_read_bio:no start line

I'm not able to sync any data with the server please help to solve this issue. You can imagine, that this is a pressing issue :confused:

Below you can find a summary of my system settings. Please inform me if additional data is needed!

Thanks!

Server configuration

  • Linux 4.4.0-62-generic #83~14.04.1-Ubuntu SMP Wed Jan 18 18:10:30 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
  • Ubuntu 14.04.5 LTS
  • apache2 2.4.7-1ubuntu4.16
  • PHP Version 5.6.31-1~ubuntu14.04.1+deb.sury.org+1
  • occ encryption:status: enabled: true, defaultModule: OC_DEFAULT_MODULE

#2

I had the same error and tried nearly everything. At the end I backed up everything and migrated to nextcloud - same error.

I then found a solution saying that the error disappeared after updating to php7.0 - I had just updated from php5 to 5.6 - same version you are using. I guess you also installed it through ondrej package?

Switch to php7.0 and see if it works! (also I have no Idea why the error occurs with php5.6...)


#3

Hey @lecoqroach,
thanks for your response!
Yes I'm using the ondrej ppa. I did some testing with 7.1 but went back after no immediate success. I shall try again, Thanks!
I did btw see some improvements after upgrading from owncloud 10.0.0 to 10.0.2.

I'm still in the process and will report back when I made progress.


#4

Did you get the same Encrypt Exception? And also with PHP7.0?


#5

I have same issue with 9.1.4 with php5.6 after moving to app marketplace. See GitHub issue #28409.

In my case I see lots of files_antivirus error messages.

Best
Christian


#6

PHP 7 solved the problem for me.
However I had following errors with encryption. The tools provided by occ are not well documented and produce unclear results. occ files:scan scanned all files of a user successfully, they were visible through the webui but access to those files was still not possible. In whole I'm pretty disappointed in owncloud.
Anyhow, I've moved to a fresh owncloud setup.