My devices can't access my Owncloud anymore

Steps to reproduce

  1. My Version 10.0.10 worked flawless for some time (over 2 years). Recently an issue came up where one of my calenders was not visible on my wife’s account although I had permitted her to access it.
  2. Thinking it might have been a little bug in my version and being aware, that my version was outdated a bit I upgraded to 10.1.1 from within the Admin account of Owncloud with the intention to upgrade further later on.

Expected behaviour

I expected a working new version

Actual behaviour

This update failed. Messages said something about missing new signatures of files which my installation didn’t have.

  1. Then I tried the update process from my Webhoster’s management account, which also failed.
  2. I then deleted the installation via webhosters management account and restored the backup which was created just before the first update trial.
    I expected to have exactly the situation as before the first update trial, since I had deleted the installation and replayed the backup.

For the moment I don’t care about the original problem with the calender.

I now can access the data via the webui exactly as before.
BUT: all my devices (MAC OS, WINDOWS 10, Android in various versions, IOS), which synced files, calenders and contacts before can not access the data anymore and therefore do not sync. The messages vary depending on the sytem, but they all say, that the login data are not valid. But entering valid data makes no difference.

Server configuration

Operating system:
Unknown, Webhoster provides the environment
Web server:
I believe apache2

Database:
mysql

PHP version:
7.1
ownCloud version: (see ownCloud admin page)
10.0.10.4
Updated from an older ownCloud or fresh install:
updated more than 2 years ago
Where did you install ownCloud from:
Administration WebUi of my Webhoster
Signing status (ownCloud 9.0 and above):
unknown

Login as admin user into your ownCloud and access 
http://example.com/index.php/settings/integrity/failed 

I don't have this path in my installation (yes, I substituded "example..." with my website)


**The content of config/config.php:**

Log in to the web-UI with an administrator account and click on
‘admin’ -> ‘Generate Config Report’ -> ‘Download ownCloud config report’
This report includes the config.php settings, the list of activated apps
and other details in a well sanitized form.

I don’t have this menupoint in my installation

ATTENTION: Do not post your config.php file in public as is. Please use one of the above
methods whenever possible. Both, the generated reports from the web-ui and from occ config:list
consistently remove sensitive data. You still may want to review the report before sending.
If done manually then it is critical for your own privacy to dilligently
remove all host names, passwords, usernames, salts and other credentials before posting.
You should assume that attackers find such information and will use them against your systems.


**List of activated apps:**
 Calendar 1.6.3
 Contacts 1.5.5
 Deleted files 0.9.1
 Federation 0.1.0
 Provisioning API 0.5.0
 Share Files 0.11.0
 Update notification 0.2.1
 Versions 1.3.0
 2-Factor Authentication 0.5.3 (only activated for Admin-Account)
 Activity 2.4.2
 Collaborative tags 0.3.0
 Comments 0.3.0
 External Storage: FTP 0.2.1
 First run wizard 1.1
 Gallery 16.1.1
 Mail Template Editor 0.4.0
 Market 0.4.0
 Notifications 0.3.5
 OwnBackup 19.5.0
 PDF Viewer 0.11.0
 Tasks 0.9.7
 Text Editor 2.3.0
 Video player 0.9.8

Are you using external storage, if yes which one: local/smb/sftp/…
No

Are you using encryption: yes/no
no

Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/…
no

Client configuration

Browser:
Firefox

Operating system:
MAC OSX, IOS, Windows10, Android in various versions

Logs

Web server error log

didn’t find it

Insert your webserver log here

Didn't find it

ownCloud log (data/owncloud.log)

Insert your ownCloud log here
really? The only file I found with this name is 230MB in size and has no entries from the time when the problem started.

Browser log

Browser access is not the problem

Bottom line:
How do I restore the sync with my devices?

Thanks a lot

  • What error message are you receiving in your clients?
  • Have you tried setting up a completely new client?
  • Are you using the latest client versions on the different platforms?
1 Like

Hey,

could it maybe possible that you are running out of storage due to the restored backup?

No, plenty of memory available

As I wrote: the messages vary depending in the system. They all say, that the Login-Data are not correct
I haven’t seen a reason, why to change the devices setup in any way, because I was just restoring a backup. So from a logical point of view the result should be exactly as when the backup was created, shouldn’t it?

Thanks for all your replies and effort.

I quit solving the problem with Owncloud (so can you) and set up a completely new sync environment using Nextcloud. It took me as much time as trying to figure out, what the solution to my OC-problem could be. I will delete my old OC Installalation soon.
I could restore all the data and can access them by all ways and devices again.

Thanks, case closed for me.