My mount point is not working on UI of owncloud webserver

Expected behaviour

Tell us what should happen : Azure Blob Storage should be mounted on Owncloud through Storage account (External)

Actual behaviour

Tell us what happens instead : Every thing is configured but mount point of Blob storage with correct path given not allowing to store any data, to blob storage.

Server configuration

Operating system:18.04 Ubuntu LTS

Web server:

Database: MYSQL/Maria DB

PHP version: version 7

ownCloud version: (see ownCloud admin page) latest

Updated from an older ownCloud or fresh install: fresh install

Where did you install ownCloud from:

Signing status (ownCloud 9.0 and above): all Good


Show output of lsblk and then output of ls -al /path/to/azure/block/storage


Am using Blobfuse to configure Azure Storage with Blob

You have to make sure that the folder that you’re trying to add as external storage is readable and writable by the user www-data.

What is the output of mount? How do you mount this blob storage on system boot?

@eneubauer kindly refer below screen shots


@eneubauer I mounted Blob storage through blobfuse by refering :-

Yes, external storage is readable and writable by the user www-data .

In the image with the permissions, it doesn’t look like it.
Can you run sudo -u www-data touch /mnt/ramdisk/blobfusetmp/test but before that run sudo -i

@eneubauer please find screen shot for above commandzzzzzzzz

How are you configuring the external storage in the UI
If you do it in the admin interface as external storage, what happens
Does it go green? Does it stay red? Do you get an error message?
Can you find a message in the logs?


Have you tried configuring it for the mountpoint you specified? Currently it is showing /root/mycontainer
Can you point it to /mnt/ramdisk/blobfusetmp?

Are you running ownCloud inside docker or not?

@eneubauer No, I am not running Owncloud inside Docker!

Shall i ? I don’t know the steps to follow!

See, it’s green now, so it should work. Can you confirm?

@eneubauer Its Green now!, I agree that

But, i want to store data in my blob through /mnt/ramdisk/blobfusetmp

When i tried adding some files, its not uploading on below screen shot location :-

Did you upload into the “Audio” folder?
If yes, is the file visible in /mnt/ramdisk/blobfusetmp?
If yes, check the logs of your mounting tool.

@eneubauer Its not visible in /mnt/ramdisk/blobfusetmp` ?

Where is the file instead (in your file system)? Can you still see it in the WebUI?