My 'owncloud' can't enter

I want to use it when I log in from my own domain name.

The facts tell me that it is impossible.When I entered it with my own domain name, I appeared the login interface I wanted. Then no matter how I clicked on the damn button, it didn’t work.When I switch to IP login, I can log in normally. I don’t know what happened.I enabled two domain accesses and one IP access, but the two domain accesses have no effect, causing me to have only IP access. You are accessing the server from an untrusted domain.
array (
0 => ‘45.***.***。190’,
1 => ‘cloud.***.site’,
2 => ‘cloud.***.life’,
I swear I did the tutorial completely.

Its operating system: Ubuntu 18.04 x64.

Web server: Apache2.


PHP version: PHP 7.2.19-0ubuntu0.18.04.2 (cli) (built: Aug 12 2019 19:34:28) ( NTS )

ownCloud version:10.0.10 (stable)

Updated from an older ownCloud or fresh install: Fresh install

Where did you install ownCloud from: Wegt

No matter how I press ‘Enter’ on the keyboard, or click on the small button, it won’t let me enter the system, but when I access it via IP, everything works fine.


could you check that your Apache vhost has the correct domains in the ServerName or ServerAlias directive ?
Do you have any cache system on PHP such as opcache ? If so restart PHP when you modify config.php to add/delete your domains.
I’d suggest you open your console browser when you try to click the button, I’m thinking there might be some CORS problem with your setup.

1 Like

This seems to be the case, I tried to restart my device and reconfigure my configuration, it worked, frustratingly I can only access through one domain and the other does not work.

But this is really good news, I just need to let another domain jump.

CS35, thank you for your help.

Hey @Cirno,

you’re welcome !
It’s a good news, I think it’s a CORS problem that you have then, did you try setting all the names in your vhost configuration and in the config.php and restart Apache and PHP ?
Could you check your browser console ? It might give you some answers.
Cheers !

1 Like