Need help with SSL setup for Apache


I need help. I am NOT an experienced Linux user so be kind :slight_smile:

I have gotten stuck in trying to configure my SSL for apache.

In this guide:

I have added the SSLOpenSSLConfCmd DHParameters /etc/apache2/dh4096.pem into my ssl.conf file wich is located in /etc/apache2/mods-enabled/ directory. I hope this is the correct place to add that.

After this the guide wants me to add “/.well-known/acme-challenge” in my Virtual host directive for port 80. But what file contains this directive ? I feel like a noob for not finding this.

Further down the guide they also want me to adopt my virtual host block. Where exactly do i find this ?

Im running Raspbian on my raspberry 3 b+

Googled like a crazy man to find answers but im a bit stuck at the moment.

Please help.


if the linked documentation doesn’t clarify all of your questions then i think it could make sense to request to add this information at the documentation tracker below so everyone can benefit from the additional information.

yes ofcourse that would be good.

at the moment im most concerned about getting help with this since i promise there are alot of people in this forum that can answer it pretty easy.

Well, even if this might be true, I’m not sure that this is a good place for getting help on a pure apache2 config topic. Personally I cannot help you on this, sorry.

Why is that? I am following a guide made by somone at owncloud or how you say it. Something in this guide is confusing me.

So what better place then this is there to ask questions about it? And as tom42 says, it would be good to update the guide to make it easier to understand for everyone.

I am happy to receive replys, but please try to stay with the topic.

1 Like


while i think the documentation on this topic could be improved we probably need to be aware that this documentation for 3rdparty components like Apache and Let’s Encrypt is provided for convenience.

The documentation probably requires to have some knowledge about that components (e.g. what is a Apache Vhost and where can i find its configuration on my setup?) and probably also can’t cover all aspects / variants of it down to the very basics.

Maybe this is what @alfredb is trying to say?

Personally i’m also not able to help on initial question as i don’t know your environment and how you have configured it. So it might be still possible (even with the github issue reported) that you need to consult the Apache / Let’s Encrypt manuals for some additional help. :slightly_frowning_face:


Ye, i look at them as guides.

Ive followed all the guides from the start here at owncloud to set up owncloud and all other things wich is needed for it.

As i said. Im using Raspbian and that is my enviorment.

I feel like this forum isnt helping me at all. It kind of wasting my time. So if any moderator see this just delete this topic.

I will find some other cloud service and some other community.

Thanks for you time.

I’m really sorry, that you didn’t find an answer you expected here in this forum.

1 Like


maybe your expectations of a forums like this are too high? Personally if i’m having issues with e.g. Apache or Let’s Encrypt i would try to ask the questions / for help in a forums related to both programs in the first place and not in a forums which are using those.

Then considering to switch too another cloud service looks to me quite drastically, maybe you can try to get some answers in e.g. one of the following resources instead?

1 Like

Fully agree with that!

1 Like

I have a similar issue. I also followed the guide and apache itself was working fine and showing all of my other subdomains allright with the letsencrypt certificate. A previously (without letsencrypt) working instance of owncloud would show up but as soon as I try to login, it would throw an error like " openssl_pkey_get_details() expects parameter 1 to be resource, boolean given" and not log me in.
I finally had to take out the “SSLOpenSSLConfCmd DHParameters /etc/apache2/dh4096.pem” and without it, it is working all fine now. I tried one full day changing config back and forth and the solution was only not using this single line! I hope this helps someone.
Cheers, Joachim

1 Like