New installation. Cannot log in as admin - only one user exists but not admin?

I have gone through the instructions here ( ) for a new installation of owncloud on a Raspberry Pi.

Everyrhing went swimmingly well, except that now I can not log in as administrator. As far as I can remember, I was prompted for only one username, and a password with verification, plus the data folder and so on. When I log in with that user (“dennis”), I do not seem to have administrative privileges. List of users only produces one row, and this is also confirmed in the oc_users table (mysql SELECT * FROM OC_USERS;)

Of course, attempts to reset passwords like this:

    sudo -u www-data php /var/www/owncloud/occ user:resetpassword <USERNAME>

with being any of: www-data, root, admin, Admin, ADMIN

all end up with a “User does not exist” message.

Again, this is a brand new installation so I would have no objection to wiping out the config and starting over, but I have not seen such instructions. Where can I go from here? System is not much good for me without an administrator since there are features I need to install for my particular goal.


Can you run the following commands:

occ user:list

and then you can use the occ group:add-member <userid> admin command to make your user admin.

1 Like

Thanks so much for your reply, and especially the command, ensubauer. Maybe the problem is that I don’t know how to use admin functions. I had already thought to do that, though:

dennis@owncloud10:/var/www/owncloud> sudo -u www-data php /var/www/owncloud/occ group:add-member -m dennis admin
User “dennis” is already a member of group “admin”

But when I access the site ( and click on settings, all the settings are greyed out. Am I using the wrong approach?

Can you post a screenshot of this. Are you in the right settings? This sounds very weird to me.

1 Like

Sure, here you are…

Those are just the apps, what happens if you click on general in the admin settings?

1 Like

Here you are. Sorry, I didn’t understand… Thanks for your patience!!!

And for your help!

Ugh. Looks like “greyed out” is the norm here, and I do have administrative functions after all. I was able to add users and enable apps, so I guess I’m OK. I apologize for the beginning-pains, this just seems so different from what I remember (version 8) and I panicked. I apologize. Thanks again for your help! In V8, there was a link in a bottom corner (right, I think) that let one choose administration mode. I’ll get used to this.