Newbie needs help

10
hosting

#1

I fix Windows computers, but I lack the knowledge to configure ownCloud properly to work well. I don't know Linux or server stuff. I hope someone will take pity on me and help.

I have a shared Linux server hosting plan. When I asked my hosting company for help with the issues, the responses were not very helpful, partly because I don't understand them.

1. Transactional file locking should be configured to use memory-based locking, not the default slow database-based locking.

I read what I could find on this, and did not understand how to solve the problem. Hosting company response:
'memcache' is enabled on the server.

---
root@mm1 [~]# php -m | grep -i mem
memcache
---

If you need the 'memcached' module, your account needs to be migrated to a newer server with latest PHP versions since the PHP version on this server does not support that module.

This response doesn't help me because I could not find any ownCloud instructions for "memcache", and what I have read on the Internet equate "memcache" and "memcached", while the hosting company's response indicates that they are two different things.

2. No memory cache has been configured. To enhance your performance please configure a memcache if available.

For this, I made sure that Redis is installed, but my attempts to create & assign a memory cache file have failed with errors.

Hosting company response:
I have already enabled memcache on the server for you.

3. Increase maximum file size from 512 MB to more than 1 GB.
...a. I think I configured it properly for ownCloud's ".user.ini" & ".htaccess" files, but I get the "Connection timed out" error when uploading a file larger than 512 MB. A 135 MB file uploaded OK.
...b. I see from the PHP options in cPanel that "post_max_size" cannot be larger than 128 MB, and "upload_max_filesize" cannot be larger than 1 GB. These are the two items that in ".user.ini" & ".htaccess" for ownCloud had to be set for the maximum file size.

Hosting company response:
I would recommend to upload the large files over FTP, or cPanel file manager.

--

The hosting company said that they will not enable HSTS because it is a shared server, so I will have to ignore that warning.

Can/will anyone here help me? Thank you!


#2

Which php version do you use? Latest ownCloud version needs PHP 7.

echo PHP_VERSION

#3

ownCloud 10.0.6 Server Administration Manual: System Requirements: PHP (5.6+, 7.0, & 7.1)
https://doc.owncloud.org/server/10.0/admin_manual/installation/system_requirements.html

So I have PHP version 5.6 installed.

I'll try upgrading to version 7.


#4

Did you set max filesize values?
https://doc.owncloud.org/server/10.0/admin_manual/configuration/files/big_file_upload_configuration.html

After that you have to restart the Apache2/nginx.


#5

I upgraded PHP to version 7. Then had to beg the hosting company to reboot the server. Once done, the same warnings are there:

  • Transactional file locking should be configured to use memory-based locking, not the default slow database-based locking. See the documentation :arrow_upper_right: for more information.

  • No memory cache has been configured. To enhance your performance please configure a memcache if available. Further information can be found in our documentation.


I already had set:

.user.ini
upload_max_filesize=5G
post_max_size=5G

.htaccess
php_value upload_max_filesize 5G
php_value post_max_size 5G

I just added:
php_value max_input_time 14400
php_value max_execution_time 14400

But I don't think I'm going to be able to get the hosting company to reboot the server yet again. It is a shared server, and they keep trying to get me to pay for a VPS, which will cost 10 times more than what I am paying now.


#6

How did you install redis?
Follow our installation (configuration) instructions on
https://doc.owncloud.org/server/10.0/admin_manual/configuration/server/caching_configuration.html
and https://www.techandme.se/how-to-configure-redis-cache-in-ubuntu-14-04-with-owncloud/


#7

I'm going to give up on ownCloud, because:

  1. I set up ownCloud for use with my family because they are using a mishmash of several other free cloud accounts. They have told me now, though, that they don't want to change.

  2. It appears that I need a VPS or a dedicated server to run ownCloud. My hosting company offers many free "apps" like ownCloud to install via cPanel, but with a shared server account, will not help with them if it means changing server-wide settings.

  3. I don't have the knowledge to do it properly.

Thank you for your time and I'm sorry that I wasted it. I know how frustrating it is for you, because I also provide support for Windows issues and programs. I don't like it when I try to help someone, and they give up.


In case you are curious...

I installed redis via cPanel. There is a "PHP Selector" where I choose which version of PHP to use, and a large list of extensions with checkboxes. I check-marked redis.

After the server was rebooted, I added a 866 MB file to the ownCloud folder last night. It took the requisite amount of time to upload (~1.5 hours), then it tried to do it again, with a timeout in the client log. I shutdown the computer for the night. Today when I booted my computer, I got an error message saying ownCloud failed to synch because it couldn't contact the server. I deleted the 866 MB file from the ownCloud folder, then restarted the client, but the client still says it cannot access the server. The webpage for my ownCloud will not load. cPanel says that I am using 100% of physical memory usage (1 GB), and 100% of I/O (1 MB). I quit the client, then started it again a half hour later. 10 minutes after that, the client was finally able to connect to the server. 5 minutes after that, cPanel finally reported the memory usage and I/O was back down to normal levels.

I'm uninstalling ownCloud now.