Nginx "This content failed to load."

10
hosting

#1

Steps to reproduce

  1. Start the server
  2. Login into owncloud

Expected behaviour

The main directory of owncloud should be dispayed

Actual behaviour

A white square apear with “This content failed to load”

Server configuration

Operating system: Ubuntu 18.04

Web server: nginx

Database: MariaDb

PHP version: 7.2

ownCloud version: (see ownCloud admin page) 10.0.10

Updated from an older ownCloud or fresh install: fresh (after upgrade not working)

Where did you install ownCloud from: from wget .bed

Signing status (ownCloud 9.0 and above):

Login as admin user into your ownCloud and access
No errors have been found.

The content of config/config.php:

{
“system”: {
“instanceid”: “oc312qfbflg2”,
“passwordsalt”: “REMOVED SENSITIVE VALUE”,
“secret”: “REMOVED SENSITIVE VALUE”,
“trusted_domains”: [
“xxx.yyy.zzz.aaa”,
“owncloud.mydomaine”
],
“datadirectory”: “/var/www/owncloud/data”,
“overwrite.cli.url”: “xxx.yyy.zzzz.aaa/owncloud”,
“dbtype”: “mysql”,
“version”: “10.0.10.4”,
“dbname”: “owncloud”,
“dbhost”: “localhost”,
“dbtableprefix”: “oc_”,
“dbuser”: “REMOVED SENSITIVE VALUE”,
“dbpassword”: “REMOVED SENSITIVE VALUE”,
“logtimezone”: “UTC”,
“installed”: true,
“updatechecker”: false
}
}

If you have access to your command line run e.g.:
sudo -u www-data php occ config:list system
from within your ownCloud installation folder

List of activated apps:

If you have access to your command line run e.g.:
sudo -u www-data php occ app:list
from within your ownCloud installation folder.

{
“system”: {
“instanceid”: “oc312qfbflg2”,
“passwordsalt”: “REMOVED SENSITIVE VALUE”,
“secret”: “REMOVED SENSITIVE VALUE”,
“trusted_domains”: [
“192.168.0.107”,
“owncloud.mydomaine”
],
“datadirectory”: “/var/www/owncloud/data”,
“overwrite.cli.url”: “xxx.yyy.zzz.aaa/owncloud”,
“dbtype”: “mysql”,
“version”: “10.0.10.4”,
“dbname”: “owncloud”,
“dbhost”: “localhost”,
“dbtableprefix”: “oc_”,
“dbuser”: “REMOVED SENSITIVE VALUE”,
“dbpassword”: “REMOVED SENSITIVE VALUE”,
“logtimezone”: “UTC”,
“installed”: true,
“updatechecker”: false
}
}

Are you using external storage, if yes which one: local/smb/sftp/…
No
Are you using encryption: yes/no
No
Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/…
No

Client configuration

Browser: Firefox


#2

Hey,

i’m running a similar setup with ownCloud 10.0.10 and nginx with the config linked below and don’t have this issue here.

https://doc.owncloud.org/server/latest/admin_manual/installation/nginx_configuration.html


#3

I think I have some information on this probleme…
My owncloud is on a server n°2 who is behind another server n°1.
The n°1 is on internet.
I have try to configure nginx on the n°1 to forward all the request to “owncloud.mydomaine” to server n°2.
When I directly connect n°2 on the internet, owncloud works fine.
So the bad configuration is on the nginx n°1.
I have the following .conf file :

server {
listen 80;

server_name owncloud.mydomaine;
index index.php;

location / {
include proxy_params;
proxy_pass http://xxx.yyy.zzz.aaa/;
}

location ~ .php$ {
include snippets/fastcgi-php.conf;
fastcgi_pass unix:/var/run/php/php7.2-fpm.sock;
}
}

any idea of some bad or missing parameter ?

thanks


#4

after returning to the initial conf with server n°1 and server n°2 no more white page with “This content failed to load”
I initialy thought that it works fine…
but in fact I can creat directory but not upload any file.
It says my Quota is 0kb…
when I go to user page configuration, my user has “default” quota.
And if 1 set it to 1GB it did not save the action…
I have the feeling that my owncloud is frozzen (I mean very few modification on the configuration is possible).