No apps listed/No internet connection/cURL error 60 message


#1

Problem

  • The app page within your installation is just showing the “Not enabled” and “Enabled” categories and not any other like “Productivity”.
  • A “No internet connection” message is shown in your admin backend
  • Your logfile is showing a “cURL error 60: SSL certificate problem: unable to get local issuer certificate”

Reasons

  • A broken, outgoing connection to the appstore (https://apps.owncloud.com)
    -> Please check via a call like: curl -i https://apps.owncloud.com if you’re able to access the appstore. This call needs to be executed on the command line of your server (via SSH).
  • cURL is using outdated versions of OpenSSL or NSS (oC 8.1.1 should show this in the admin backend)
    -> You need to upgrade those versions to recent ones like stated here.
  • A missing config/ca-bundle.crt (Might be caused by a buggy updater app https://github.com/owncloud/updater/issues/164), for OC 8.1.x you can download it directly from github: https://raw.githubusercontent.com/owncloud/core/stable8.1/config/ca-bundle.crt This doesn’t apply for oC 8.2.x!!!
  • A disabled appstore (‘appstoreenabled’ => false, in your config.php)
  • A wrong configured appstore URL (Remove ‘appstoreurl’ => from your config.php)
  • Empty or wrong configured ‘proxy’ => ‘’, in config.php
  • A broken, outgoing connection to https://www.owncloud.org)
    -> Please check via a call like: curl -i https://www.owncloud.org if you’re able to access the page. This call needs to be executed on the command line of your server (via SSH).

Additional info

Feature request to be more verbose on this: https://github.com/owncloud/core/issues/18269

Temporary workaround:

  • Download app from apps.owncloud.com
  • Extract the folder into your apps folder (/path/to/owncloud/apps)
  • App should show up in the list of “not enabled” apps. Enable it.
  • You have some time to fix the problem.

#2