No connection of Owncloud client on Ubuntu 17.10

help

#1

Hi all,
I have been trying to connect my owncloud client with the drive of my university. At the begiunning it worked, but now it is not connecting at all. The version is 2.4.2 (build 9883).
This is what happens:
I start the client, and it says that it is not logged in. When I try to log in, it opens a tab in my browser and asks for the credential. I type them and it sends me to the folder of the server where my data is. So it connected through the browser just fine. However, the files in the server are not synced with the files on my computer.
On the owncloud client side, it says “Obtaining authorization from the browser. Click here to re-open the browser” (that doesn’t help). But it never connects…
I already uninstalled and reinstalled but it did not work.
Can someone please help me? I am new to linux and have no experience with servers etc.
Thanks!


#2

Hey,

if this is not your own server then i think there is not that much you can do from your side.

Personally i would check which ownCloud version your University is running, then check if its the latest version 10.0.9 of ownCloud and maybe i would also contact your support contact of your University.


#3

As @tom42 said, I would ask the admins what has changed.


#4

Hi!
Thank you so much for you answers. I conntacted my ICT unit. There was nothing wrong with the server. It turns out that Firefox was not “passing” the authentication back to the owncloud client (sorry if my description doesn’t make sense). For future reference here is how we solved it:
0. Remove the synchronization with the folder and close owncloud client

  1. Set another browser as default
  2. Start owncloud again. And proceed with the authentication. Add the folder again to synch.

I don’t know why firefox was not working (clearing the cookies also didn’t help). But this solved the problem. If someone has any idea why this might have happen I would be very curious to learn the reason.
Thanks for your help!