No connection to owncloud - connection timeout

I’ve been using Owncloud for a number of years without any problems and have made no changes to the server or the client; but recently the client cannot connect to the server and times out/aborts. I downloaded a fresh version of the client and did a clean install but the issue remains.

Can log in via browser no problem and upload/download files/folders without issue; although it must be noted that using all browsers this has also become very slow.

As mentioned, no changes have been made other than new small files added to the sync folder.

Expected behaviour

Local folder syncs to server

Actual behaviour

Desktop client is logged in and connected to the remote server but when attempting to sync, gives errors and does not sync

Also when fetching folder list from server also fails with message: ‘no connection to owncloud at www.ourserver.com timeout connection timeout’

Steps to reproduce

  1. Connect to Desktop Client
  2. Choose local folder to sync, choose remote folder
  3. Error messages in ‘Activity’ ‘Not Synced’

Server configuration

Operating system:
Linux

Web server:

Database:
My SQL 10.3.2.2

PHP version:
7.3

ownCloud version:``
10.3.2

Storage backend (external storage):
None

Client configuration

Client version:
2.10.1 (Build 7187)

Operating system:
OSX Monterey 12.4

OS language:
English

Installation path of client:
applications/owncloud

Logs

  1. Client logfile:
    https://gist.github.com/icomputeUK/d304bd056699952d70b36390efb7f9f1

  2. Server logfile: ownCloud log (data/owncloud.log):
    https://gist.github.com/icomputeUK/530bbb3e28ca77663e62e09ff5690e6d

Hi iCompute_UK,

in your owncloud.log I can see that there are severe database and memory issues:

General error: 2006 MySQL server has gone away

Failed to connect to the database: An exception occured in driver: SQLSTATE[HY000] [1040] Too many connections at ...

Out of memory (allocated 123731968) (tried to allocate 376832 bytes) at ...

Too me it looks your database keeps crashing due to memory outage.
Unforunately, at this step the other log entries wouldn’t be any help.

I suggest to double check your database server sanity and then try again.

Edit: Additionally consider upgrading your ownCloud instance. 10.3.2.2 is quite an old version and lots of performance issues had been solved since then. Still, first have a look at your memory/database

Thanks Cortho,
I noticed those errors and contacted our hosting company who supposedly increased our memory allocation. We don’t have our own server but it’s not shared.

I intend to update to the latest Owncloud version but am trying to limp along at the moment as our customers are UK schools so we can’t afford any issues with upgrading.

My experience of installing Owncloud in the first place was a nightmare so I need to wait until schools are on summer vacation here before I mess around with that.

1 Like

I’m glad you figured out the memory issue.

You might want to test the upgrade on a cloned system (or on a local system using a database dump). In my test cases I only sync that user’s data directory who will be my test user.

Still I can see your point why you would be waiting, sometimes a test run is behaving differently than performing the same steps on the live server :wink: