No database drivers (sqlite, mysql, or postgresql) installed. PHP module zip not installed

Just can’t get this to work. All ways get PHP Module not installed and No database.

I got a screen shot of it on my google drive here.

I keep editing /etc/php/7.1/apache2/php.ini and 2 others 7.2 and 7.4 php.ini files.

Added this to them.

Because looked on Google for help and added one line at a time but seems like nothing helps.

I do restart Apache with service apache2 restart and refresh the ownCloud page and it gives me the errors in that screen shot link.

It’s a Ubuntu server here is a command line:

root@sg30:~# uname -a
Linux sg30 4.15.0-88-generic #88-Ubuntu SMP Tue Feb 11 20:12:47 UTC 2020 i686 i686 i686 GNU/Linux

It says i686 but it’s a 32-Bit CPU. so i386.

Ubuntu Linux 18.04.4 32-bit.

Looking on Google the links I did are all colored so I looked at them all ready.

If I look at web pages that tell how to install it. I did that like 3 times thinking it my work then. Then the screen shots they show is just log in not full a error’s like I get.

-Raymond Day

PHP 7.4 is not yet supported by ownCloud, use PHP 7.3 instead.

  1. Check which PHP packages are installed:
dpkg -l | grep php
  1. Make sure all modules required modules are installed in the desired PHP version.
  2. Make sure you’re not running PHP-FPM
  3. Find out which PHP version is currently active in Apache:
file /etc/apache2/mods-enabled/php7.*.conf
  1. Disable old versions of PHP in Apache
a2dismod php7.x
  1. Enable new version of PHP in Apache
a2enmod php7.3
  1. Find out which PHP is active in the CLI with the following command:
update-alternatives --display php
  1. Enable PHP version 7.3 by running
update-alternatives --config php
# Follow the interactive menu
  1. Restart apache
#check configuration
apachectl -t
# If Syntax OK restart apache, otherwise correct mistakes
systemctl restart apache2
# Double check it really came back up
systemctl status apache2
  1. Go to ownCloud website, check if error persists.
  2. If yes create a phpinfo like so
echo "<?PHP phpinfo(); ?>" > /path/to/owncloud/info.php
  1. Go to http(s?)://owncloud.domain.tld/(subfolder/)info.php & check in the website which PHP with which modules is loaded

It might be that some PHP modules are not available for 32bit, as I vaguely remember 32bit support being discontinued for Ubuntu. But I’m unsure with which version they might stop 32bit support.

1 Like