No files left after update - pls help


two days ago I updated my owncloud instance. The update failed somehow. I had code integrity issues and some hassle with the overall update processe.
Who cares, I thought, I had made an backup before and wanted to go back. But the backup I initiated in the backend of my hosting provider is corrupted. I seems, that it didn’t run through. So now I have a corrupt backup.
That is still not a big problem, since die hoster regulary backups the whole files, so I have another backup as well, which should be good enough.
The main problem I have now is, that I don’t know, how to get my files showing up in my account again. I think it is database related. Since the backup of the hoster I manuallly initiated didn’t finish, it also didn’t finish the database backup.
So can anybody give me a hint, how I get the files back into the accounts. If the history is gone, that is accaptable. But all the files, which were actually there, should be accessable again.
Any hint for me?

I only have restricted access via ssh, no occ commands though. The current version running is I tried to update to 10.4.1 via manual update.

Thanks for your help.

Your description is far too vague to be able to help. Sorry.

1 Like

Thank you for your reply.
I was looking for, just install the latest version you used, link the data dir and all will be back. Or make a new database. It will rebuild after you initiate a file scan. But it seems, it is not that easy.

I restored the whole cloud folder (not the database though). But no luck. No files sync back.

I browsed the backend and looked at latest activities. There was a file change of a file, which I can’t see or access anymore. After clicking on it I can access it through the web client and I see the root folder of this share again.
After loggin out and in again the client starts to sync, but after a minute it stops syncing stating 500 Internal Server Error for every file.
WTF is going on there?!