No marketplace connection: cURL error 7: Failed to connect to localhost port 1080: Connection refused

Steps to reproduce

  1. In try to go to /app/market
  2. I get an error: No marketplace connection: cURL error 7: Failed to connect to localhost port 1080: Connection refused

Expected behaviour

I should be able to reach the app market and search/install applications.

Actual behaviour

I get an error saying that I am trying to connect to a local host marketplace.

Server configuration

Operating system:
Diet Pi Debian Distribution

Web server:
Apache
Database:
MYSQL
PHP version:
7.3.29-1~deb10u1
ownCloud version:
ownCloud 10.8.0 (stable)
Updated from an older ownCloud or fresh install:
Updated from older version, but had the problem before.
Where did you install ownCloud from:
Starting from the Diet Pi package, however, upgraded based on instructions from the official website.

The content of config/config.php:

{
    "system": {
        "passwordsalt": "***REMOVED SENSITIVE VALUE***",
        "secret": "***REMOVED SENSITIVE VALUE***",
        "trusted_domains": [
            "localhost",
            "sw-tiger.com",
            "192.168.0.186",
            "pi-jenkins",
            "192.168.0.36"
        ],
        "overwritehost": "sw-tiger.com",
        "proxy": "192.168.0.36",
        "overwriteprotocol": "https",
        "datadirectory": "\/mnt\/dietpi_userdata\/owncloud_data",
        "overwrite.cli.url": "http:\/\/localhost\/owncloud",
        "dbtype": "mysql",
        "version": "10.8.0.4",
        "memcache.local": "\\OC\\Memcache\\APCu",
        "filelocking.enabled": true,
        "memcache.locking": "\\OC\\Memcache\\Redis",
        "redis": {
            "host": "\/run\/redis\/redis-server.sock",
            "port": 0
        },
        "dbname": "owncloud",
        "dbhost": "localhost",
        "dbtableprefix": "oc_",
        "mysql.utf8mb4": true,
        "dbuser": "***REMOVED SENSITIVE VALUE***",
        "dbpassword": "***REMOVED SENSITIVE VALUE***",
        "logtimezone": "UTC",
        "apps_paths": [
            {
                "path": "\/var\/www\/owncloud\/apps",
                "url": "\/apps",
                "writable": false
            },
            {
                "path": "\/var\/www\/owncloud\/apps-external",
                "url": "\/apps-external",
                "writable": true
            }
        ],
        "installed": true,
        "instanceid": "ochpczrmqnat",
        "maintenance": false,
        "mail_domain": "***REMOVED SENSITIVE VALUE***",
        "mail_from_address": "***REMOVED SENSITIVE VALUE***",
        "mail_smtpmode": "smtp",
        "mail_smtphost": "***REMOVED SENSITIVE VALUE***",
        "mail_smtpport": "465",
        "mail_smtpauthtype": "LOGIN",
        "mail_smtpauth": 1,
        "mail_smtpname": "***REMOVED SENSITIVE VALUE***",
        "mail_smtppassword": "***REMOVED SENSITIVE VALUE***",
        "mail_smtpsecure": "ssl",
        "loglevel": 2
    }
}

List of activated apps:
None

Are you using encryption: yes/no
No

After seeing post: https://central.owncloud.org/t/this-server-has-no-working-internet-connection/10921

I understood that my Owncloud app tried to connect through a proxy, which was set to localhost.

After removing the proxy field in my config.php the error disappeared.

1 Like