No Share Icon - How to Enable?

,

Hi,

I am using OC 10.6 on Debian.

When my users log in to the web interface they do not see the “share” icon on any files. Thus, they can only create private links.

But they are not able to share files to any other users nor by link.

This is how it looks like:
grafik
Any idea wheare I should look at?

Thanks!

/KNEBB

Hey,

maybe the following documentation provided by the ownCloud people shows / helps how to share the file?

https://doc.owncloud.com/server/user_manual/files/webgui/sharing.html#creating-shares

If it doesn’t help then i think there could be various things you could check:

  1. Try a different browser, maybe something is preventing the icon to be shown?
  2. From what i know the share functionality is provided by the “Share Files” app, maybe this is disabled or disallowed for the user group?
  3. ownCloud also provides a wide range of settings (https://demo.owncloud.org/settings/admin?sectionid=sharing), could it be possible that some of them have been changed and are disallowing the users to share files?
  4. If these are external storages then it seems there is a separate configuration option provided by ownCloud to allow / disallow sharing: https://doc.owncloud.com/server/10.7/admin_manual/configuration/files/external_storage/configuration.html#mount-options

@knebb Maybe you have restricted the use of the Share Files app to admin only? Looks like that, as you can see the icon but your users don’t.

2 Likes

Hi,

thanks @alfredb. Indeed, the issue have been by the Share Files App. It has not been restricted, but it has been disabled… :roll_eyes:

So I enabled the app and I expect it will be working afterwards.

However, I am having issues with my setup. Trying to install (and update) the app fails with “integrity error”. I will create a second post for this issue and reference here.
So far I will mark your answer as solution.
[Edit] After fixing the integrity error my users can share their files as expected. Thanks again

Thanks!

/KNEBB

2 Likes