Not able to connect from outside LAN


#1

Please help us by providing the following info. Before posting please make sure that you're running the latest available version for your oC release: https://owncloud.org/changelog/ + https://owncloud.org/changelog/desktop/

Steps to reproduce
1.Trying to log in to oc server
2.Writing in external IP or domain
3.

Expected behaviour
Getting a connection up and running

Actual behaviour
No connection with oc server

Client configuration
Client version:Version 2.2.4 (build 6408)
Client operating system:Win10

Server configuration
Operating system:Unraid 6.2 server
Web server:?
Database:?
PHP version:?
ownCloud version (see ownCloud admin page):ownCloud 8.2.7 (stable)
Updated from an older ownCloud or fresh install: fresh install
ownCloud log (data/owncloud.log):
{"reqId":"xzbqdy3gL7B6ZvKvS5Wq","remoteAddr":"","app":"PHP","message":"fopen(\/var\/www\/owncloud\/config\/config.php): failed to open stream: No such file or directory at \/var\/www\/owncloud\/lib\/private\/config.php#188","level":3,"time":"2016-10-10T18:27:02+00:00"}

{"reqId":"F9Ce6JTnD9sYWDUghfm9","remoteAddr":"192.168.0.102","app":"index","message":"Exception: {\"Exception\":\"OC\\NeedsUpdateException\",\"Message\":\"\",\"Code\":0,\"Trace\":\"#0 \\/var\\/www\\/owncloud\\/lib\\/private\\/app.php(118): OC_App::loadApp('files')\n#1 \\/var\\/www\\/owncloud\\/lib\\/private\\/util.php(130): OC_App::loadApps(Array)\n#2 \\/var\\/www\\/owncloud\\/lib\\/base.php(852): OC_Util::setupFS()\n#3 \\/var\\/www\\/owncloud\\/index.php(39): OC::handleRequest()\n#4 {main}\",\"File\":\"\\/var\\/www\\/owncloud\\/lib\\/private\\/app.php\",\"Line\":139}","level":3,"time":"2016-10-11T19:41:51+00:00"}
{"reqId":"Kkq+2m1gitEvDI8fu1eT","remoteAddr":"192.168.0.102","app":"core","message":"starting upgrade from 8.2.2.2 to 8.2.7.1","level":0,"time":"2016-10-11T19:41:53+00:00","method":"GET","url":"\/core\/ajax\/update.php?requesttoken=AmkoEzBgbR8JDgdVdiEiamMLJAQgVH0ODW1Zam1X%3Ax0ccvQ8TQDv8GJIZ6EQOjf96uT5845"}

Special configurations (external storage, external authentication, reverse proxy, server-side-encryption):Not that i know of.

I have forwarded the following ports on my router: 20, 21, 53, 443, 80, 1723, 8000. No luck.


#2

Do you get any connection to your server? You could run tcpdump on your server and see if external requests reach your server at all. If that is not the case, the port forwarding is not working (perhaps you haven't set it up properly, need to restart the router or your provider doesn't allow this). Search for port forwarding issues with your router model and ISP as well.


#3

How did you setup the oC server?

I can see following message above:

{"reqId":"xzbqdy3gL7B6ZvKvS5Wq","remoteAddr":"","app":"PHP","message":"fopen(\/var\/www\/owncloud\/config\/config.php):
 failed to open stream: No such file or directory at 
\/var\/www\/owncloud\/lib\/private

Did you use the installation instructions or is that a migration?


#4

I will try tcpdump and see if the external connection is working. Might also be a problem with the router provided by my ISP. Wasnt sure on how to check that the port forwarding actually worked. SHould have been a proper test tool for this.

EDIT:
I have no idea on how tcpdump works. I will call my ISP provider and see if they can help me resolv the matter.


#5

I installed it on a UnRAID server using Docker. There was a preconfigured setup there that I used and it downloded all the files and installed it. It works fine inside the LAN when using the WEBGUI. I can not connect to it when trying to use the pc client though.


#6

Can you ping the server? If not I recommend to use traceroute on a Linux-Client or tracert on a Linux-Client at first. You can see with that which hops (routers) will be used and whether you can arrive the server.
If you can arrive the server with traceroute/ tracert, use Wireshark on the Windows client and tcpdump on the server. You can watch the data packages and what the application is doing there.


#7

Not sure how to ping the server itself when it is behind the router. Usally i just ping the extrernal adress, but how do I ping machine inside the LAN?

I have no access to any linux client so I hope there is a way to check this with windows.
I will check out wireshark on windows.

EDIT: Have installed wireshark, but not sure what i'm looking for. Have never used this software before. Any tip on what I should look for here?


#8

Did you use a public IP for ownCloud? It seems "No" and the problem/ issue.
You should use port forwarding with a special port (like 8080) for ownCloud on the router and using the public IP of your router: http://www.howtogeek.com/66214/how-to-forward-ports-on-your-router/
You have to configure the apache port based then.


#9

I have not used a public port on my server.
I have now forwarded port 8080 on my router, but still no contact.

I cant even get the owncloud client on a pc in the LAN to connect! That is really strange in mye opinion. SHouldnt I just have to type in the local ip to get that to work?

EDIT: Really appreciate the help!:slight_smile:


#10

Hi,

you probably need to start learning how to debug network related issues on your own as the other people in here have already advised. Everything else are just guessing games.


#11

You will need a DNS entry for the public IP. After that you should be able to connect the sever, if there isn't any firewall issue any more.


#12

Hi.

I was not aware that it should be so complicated to get owncloud to work. Have never had any issues with synology server that worked flawless regarding access.

I could access my photos, music, files and whatever but when it comes to this it is just impossible and you have to learn a whole technology regarding network to set it up.

I have never had any issues forwarding ports before and using no-ip service, but this software just might be to complicated when I cant even get it to work within my own lan.... :slight_smile:


#13

Networking issues are not ownCloud issues. Its up to the admin / network operator (basically you) to get the infrastructure up and running. If that whole setup is not working every software won't run...

And as you're using docker you have added another layer of complexity to your environment where you seems to not understand the basics for.


#14

It seems you are 100% certain that the issue is my network even though everything works flawless. Well. Might be. I was only hoping that there might be someone in here that was using docker too and could give some hints.

Was not my intention to bother anyone. I'll see if I can find some help elsewhere.

Tbanks to the people that have tried though! :laughing:


#15

Well, ownCloud is a web application written in PHP. It can't cause connection errors or network issues as it is just served by your webserver on the configured port (mostly 80/443) of that server.

Instead of seeking help "somewhere else" you could follow the advise posted above to do a short research on your own how to do such network debugging.