Not able to upload PDF on my owncloud

Hi:

I installed owncloud on my server, everything is ok. So far no problems with installation, but when I access to upload the only thing I having an issue is the PDF files, for any reason I am a not able to upload or save this type of files.

Steps to reproduce

  1. Access as a registered user
  2. Select the file I want to upload
  3. Drag and drop to owncloud on the web browser

Expected behaviour

completed the upload and see the new file on my owncloud

Actual behaviour

Show a status bar saying: “a few seconds left”. the bar finishes the progress, file not uploaded.

Server configuration

Operating system:

**Web server: apache

**Database:My SQL

**PHP version: 7

**ownCloud version: 10.2.1

**Updated from an older ownCloud or fresh install: Fresh install

**Where did you install ownCloud from: owncloud.org. downloaded the uploaded to my server


https://gist.github.com/karosuu/3b976e15f065339427b723c760a876f3

Hello,

it seems you have some integrity issue according to your gist, did you modify anything in the ownCloud core ? Could you go to the URL http://you_url/index.php/settings/admin?sectionid=general and look if you have any security error ?

Before you upload a file, I’d suggest you open the web browser console, then you do the upload, you might have some informations. Also, think about checking the logs and increasing verbosity.

Did you try with several PDF files ? One might be broken and maybe ownCloud doesn’t save it.

2 Likes

Hi:

I went to settings links but, and this is what i see.
Also tried different PDF and with different user tried to upload and does not work, it’s always same behavior.

Hey,

i think you should click on each link behind the messages and try to fix these warnings first.

1 Like

Hello,

well the “worse” here is about the integrity check, as @tom42 said, click on List of invalid files and check why they are listed.

Also did you check the log and increase the verbosity ?

1 Like

These are the files from invalid files also it’s weird because prior the default.php and user.php was not there and i haven’t modify anything:
Is there any specific file I need to to edit to increase verbosity?

Results

  • core
    • INVALID_HASH
      • core/img/background.jpg
      • core/img/favicon.ico
      • core/img/favicon.png
      • core/img/logo-icon-175px.png
      • core/img/logo-icon.svg
      • core/img/logo-mail.gif
      • core/img/logo.png
      • core/img/logo.svg
      • core/templates/layout.user.php
      • lib/private/legacy/defaults.php

No need for this. But you should restore all the mentioned files from your versions tarball.

1 Like

I even tried to make a new installation for owncloud with nw data base, no modification on icons or anything, have no warning or security messages and even that way i can’t upload PDF file.

Then it’s definitely time to get into the logs, as requested in the template, IIRC.

Do both methods to upload fail, by drag and drop or by file select?

1 Like

Has a solution been found for this? I am having the same issue. I found that I am able to upload only through the Desktop application but I am not able to upload from the IOS app or the website itself. This makes it difficult to use the program. My installation is a new manual installation from to a new subdomain.

No solution so far, haven’t been able to fix this problem. It’s kind of annoying

alfredb:

None of the methods is working, not able to upload. I

Maybe yes! But we still haven’t seen any log-snippets yet. Guessing into the blue is indeed annoying. :roll_eyes:

2 Likes

What logs do you need

owncloud.log in your data directory (if you haven’t changed that) would be a good start. Make sure to paste only the relevant parts with the failed upload. You can also have a look in your apache access and error logs, though I doubt there will be much.

1 Like

Now I am not able to login with any user, I am receiving this message: You took too longin, please try again now.
{“reqId”:“fD1Ss0yGnEEnHpCIjw7B”,“level”:3,“time”:“2019-09-17T22:04:02+00:00”,“remoteAddr”:"",“user”:"–",“app”:“PHP”,“method”:"–",“url”:"–",“message”:"Undefined index: SERVER_PROTOCOL

{“reqId”:“fD1Ss0yGnEEnHpCIjw7B”,“level”:3,“time”:“2019-09-17T22:04:02+00:00”,“remoteAddr”:"",“user”:"–",“app”:“PHP”,“method”:"–",“url”:"–",“message”:"Undefined index: REQUEST_METHOD

{“reqId”:“fD1Ss0yGnEEnHpCIjw7B”,“level”:3,“time”:“2019-09-17T22:04:02+00:00”,“remoteAddr”:"",“user”:"–",“app”:“PHP”,“method”:"–",“url”:"–",“message”:"Undefined index: REQUEST_URI

I recommend searching this error in the forums, I think there are already multiple threads about it.

1 Like