Not connecting to owncloud on seagate personal cloud


#1

hi there,

i'm not connecting to owncloud on seagate personal cloud. i get the following warning when I try to connect;

You are accessing the server from an untrusted domain.
Please contact your administrator. If you are an administrator of this instance, configure the "trusted_domain" setting in config/config.php. An example configuration is provided in config/config.sample.php.

how can I solve this problem?


#2

Hey,

have you tried to use the search engine on top of this forums which is the first thing i'm always doing. You should find quite a lot threads discussing exactly this trusted domains topic.

Another question is if you have followed the message and had a look at the config/config.sample.php showing you an example and some additional notes on how to configure this?

Something similar like a search here is also possible in the ownCloud documentation. I did the following search there:

https://doc.owncloud.org/server/latest/admin_manual/search.html?q=trusted+domain

and found:

https://doc.owncloud.org/server/latest/admin_manual/installation/source_installation.html?highlight=trusted%20domain#managing-trusted-domains

For now i would suggest to have a look at the resources above for the "how can i solve this problem". I think the people are happy to answer any specific question you have on that topic.


#3

hi tom42,

yes, i tried to use the search engine! owncloud not run on macos, windows or gnu/linux. therefore, i'm not configuring the "trusted_domain" setting in config/config.php on seagate personal cloud.


#4

I think it doesn't matter on which OS your ownCloud is running. You probably just need to find this config.php on that Seagate Personal Cloud and configure it accordingly to the resources provided previously.


#5

dear tom42,

do you know these resources that were provided before?

if you do not know, thank you for your interest. bye.

and again,

hi there,

i'm not connecting to owncloud on seagate personal cloud. i get the following warning when I try to connect;

You are accessing the server from an untrusted domain.
Please contact your administrator. If you are an administrator of this instance, configure the "trusteddomain" setting in config/config.php. An example configuration is provided in config/config.sample.php._

how can I solve this problem?


#6

I know the resource of the config.sample.php (which is mentioned in your posted message) and have used the example provided in there to configure the trusted_domain setting on my own installation.

But the previous posted https://doc.owncloud.org/server/latest/admin_manual/installation/source_installation.html#managing-trusted-domains i had found seems to me even more descriptive and contains a lot more information then the config.sample.php. Thats the reason why i had posted it additionally.

Addition

As it seems to me that you're struggling with the instructions already provided in the ownCloud documentation i'm trying to explain the steps i did to configure this on my own installation.

  1. Access the URL ownCloud is running via the browser and get the "untrusted domain" message
  2. Note down the URL (e.g. cloud.example.com) on a notepad
  3. Access the server ownCloud is running via SSH / FTP
  4. Locate the config.php of ownCloud
  5. Use a text editor like vim / nano to edit the config.php
  6. Look out for the "trusted_domain" setting and update it accordingly

If 6. looks like the following:

'trusted_domains' => array(
   0 => 'localhost',
),

update it so it looks like:

'trusted_domains' => array(
   0 => 'localhost',
   1 => 'cloud.example.com',
),

The steps are basically whats described in the documentation at https://doc.owncloud.org/server/latest/admin_manual/installation/source_installation.html#managing-trusted-domains and is matching the steps i did to configure this.