Not enough free space, you are uploading XXXKB but only 0 b is left on raspbian install


#1

Steps to reproduce
1. Try to upload any file

Expected behaviour
It should upload it

Actual behaviour
The upload fails with this message: "Not enough free space, you are uploading XXXKB but only 0 b is left"

Server configuration
Operating system: Raspbian Linux raspberrypi 4.4.34+
Web server: nginx
Database: mysql
PHP version: 5.6.28-0+deb8u1
ownCloud version (see ownCloud admin page): 9.1.5 (stable)
Updated from an older ownCloud or fresh install: updated from 9.0.9
Special configuration (external storage, external authentication, reverse proxy, server-side-encryption):

external storage, https, SSL certificate with letsencrypt

ownCloud configuration

{
    "basic": {
        "license key": "",
        "date": "Tue, 25 Apr 2017 19:19:40 +0000",
        "ownCloud version": "9.1.5.2",
        "ownCloud version string": "9.1.5",
        "ownCloud edition": "",
        "server OS": "Linux",
        "server OS version": "Linux raspberrypi 4.4.34+ #930 Wed Nov 23 15:12:30 GMT 2016 armv6l",
        "server SAPI": "fpm-fcgi",
        "webserver version": "nginx\/1.6.2",
        "hostname": "",
        "user count": 3,
        "user directories": 3,
        "logged-in user": "root"
    },
    "integritychecker": {
        "passing": false,
        "enabled": true,
        "result": {
            "core": {
                "INVALID_HASH": {
                    ".htaccess": {
                        "expected": "ab5f4c44ba2f9c66f2ed25c3ad3d84660b2808cca11ffa8fe2778a648a054d8ada495a0bf4715dc873aac1efe8dfd92a72f9a24441d8f5240834e639325fd892",
                        "current": "4a97aae4d05df89a28bf2e63fe2a31cdf2afe74d3c9f622afb581d6b0f1f4e001639c7c3a31d7aaa793c00d5f355e0bfaad62ec45507245de441cfc552115cd7"
                    }
                }
            }
        }
    },

ownCloud log (data/owncloud.log)

empty

Integrity status for oC9+

Results
=======
- core
	- INVALID_HASH
		- .htaccess

It worked in the past, but in some moment it stopped working and now won't let upload anything. i suspect it could have somthing to do with nginx configuration, but i've tried lots of things with no luck. I've seen i think all of the issues about this, but they all apply to older owncloud versions. I hope anyone could shed some light on this problem. Thank you.


#2

Most likely that you have exactly the problem the message you're getting is pointing you to:

Not enough free space

Have you checked the free space on your device?


#3

Thank you for your answer. Well,yes,of course i checked the free space. The problem arise on local storage (sd card) and also in external storage(hdd). I also checked the quota settings (disabled)


#4

Could you post the output of:

df -h

from your console?


#5

Sure

df -h
S.ficheros     TamaƱo Usados  Disp Uso% Montado en
/dev/root        7,3G   5,2G  1,8G  75% /
devtmpfs         214M      0  214M   0% /dev
tmpfs            218M      0  218M   0% /dev/shm
tmpfs            218M   4,5M  213M   3% /run
tmpfs            5,0M   4,0K  5,0M   1% /run/lock
tmpfs            218M      0  218M   0% /sys/fs/cgroup
/dev/mmcblk0p1    63M    21M   43M  34% /boot
/dev/sda1        112G   531M  112G   1% /mnt/hdd1

#6

Please show your config in config.php like it:
'datadirectory' => '/mnt/hdd1',


#7

Datadirectory is /var/www/owncloud/data. The hdd storage is configurated using the External storage support application 0.6.0


#8

Please be aware that the uploaded files will always end up in / so with the current free disk space you can upload a max. of 1.8GB.


#9

Yes,but i've tried with a few bytes length files. I does not matter file size,it always says 0 bytes left.


#10

Ok, then please report a new issue to the ownCloud devs at https://github.com/owncloud/core/issues