Oauth 2 Not Updating

client-development

#1

I am operating Moodle together with OwnCloud, and recently updated the OAuth 2 plugin in OwnCloud to a newer version. However, since then, Each time I try to authenticate from Moodle I receive the following error:
error/Could not upgrade oauth token
Has anyone else had this problem?

It will be a total pain if I have to delete the pairing in Moodle, and reconfigure it all again. :frowning:
Thanks,
Paul


#2

Trying to configure OwnCloud in a test Moodle and I get the following when using the configuration laid out in the Moodle documentation.

error/Could not discover end points for identity issuerOwnCloud


#3

So ok, I have tried to configure this on several platforms, and using different OwnCloud instances, it refuses to connect at present. Could there be a bug in the OAuth2 configuration file in OwnCloud?


#4

Does this error occur if you use the previous version of OAuth?


#5

That is a good question. The old version has been replaced by the new version on both sites. But it was working before the upgrade.


#6

What you can do is, download the previous version and just replace it in the ownCloud apps folder.

Can you try this and report back?


#7

Hey,

what i’m missing here is basic information like used versions of the ownCloud server and the clients. I think those are absolutely mandatory information everyone should try to provide.


#8

Yep, I’ll do that and provide feedback.

tom42, everything is the very latest version of software and plugins, but I’ll post that information.
OwnCloud is 10.0.9
Oauth2 version 2.0.2.3
I hope that helps.


#9

Hey,

what about the version of the sync client? :slightly_smiling_face:

I’m asking because the following post is mentioned something “important” for OAuth2 users:


#10

Hi Tom42,
I’m running 2.4.3 and everything is working fine.
The iPhone app is working just fine too, which makes me wonder whether or not I’m looking at the wrong end. :roll_eyes:


#11

Ok, I seem to have resolved the issue. During configuration on Moodle you have an option to “Authenticate token requests via HTTP headers” via a checkbox. This was not checked.

I have no idea how it became unchecked since I have not touched the setup untill it stopped working, but it took a long time to find the problem, but in the end I created a completely new Moodle installation, and followed the setup instructions ste-by-step, and it worked. :slight_smile: