Oauth2 Error after update

Since update 2.9.0 the client shows “Oauth2 error - Oauth2 authentication requires a secured connection.” I can’t do anything, even a reinstall does no change, the message also appers when i click on “Open browser again” to do the challenge. I use the latest Firefox.

OAuth requires https connection. Non-secure http connection is no longer supported.

Workarounds:

  • enable https – it’s really easy with let’s encrypt nowadays
  • or disable OAuth 2.0
  • or continue with pre-2.9 versions

I figured it out today by myself - i found it nowhere described or in a changelog.
Ok now i enabled https - on two clients i cant login cause after entering username, password and token a message says: “Request not valid - contact your administrator.”
I deleted the authorized client under security in my settings and reinstalled Oauth2 - no change.
Help would be appreciated and thank you!

Message in the desktop client or in the web UI. Could you post a screenshot for better context?

In the web UI after i enter my token.
2021-09-16 07_39_56-ownCloud

Sounds morelike a config issue. Maybe check this from the docs:

If you are hosting your ownCloud installation using the Apache web server, then mod_rewrite and mod_headers modules must be installed and enabled.

You can find more information here:
OAuth2 :: ownCloud Documentation

I dont run my own webserver, i use a hosted one from allinkl.com.
So i cant edit anything there or in PHP. I still wonder why i had no and never problems with that and
suddenly after update to 2.9.0. everything went wrong even the issue with SSL - is there an alternative to Oauth2 when i want to use TOTP with the Windows desktop client or Android?

You can log into the web UI with TOTP, then generate an App Password, then use this to login to desktop and mobile apps without OAuth 2.0.