oC: 10.6 Mail Sender Address don't work with SMTP

Has anyone also been able to determine the problem or have an idea for a solution?

Steps to reproduce

  1. Set up mail notification for SMTP
  2. Send email test

Expected behaviour

Tell us what should happen
E-mail sender should my address form the config.

A few weeks/months ago it worked correctly. Is it possibly a problem with 10.6?

Actual behaviour

Tell us what happens instead
SMTP Address (login data) from my mail account.

Server configuration

Operating system:
Raspbian GNU/Linux 10 (buster)
Web server:
Apache/2.4.38 (Raspbian)
Database:
MySQL/MariaDB-Version: 15.1 Distrib 10.3.27-MariaDB
PHP version:
PHP-Version: 7.3.27-1~deb10u1
ownCloud version: (see ownCloud admin page)
10.6
Updated from an older ownCloud or fresh install:
updated
Where did you install ownCloud from:

Signing status (ownCloud 9.0 and above):

Login as admin user into your ownCloud and access 
http://example.com/index.php/settings/integrity/failed 
paste the results into https://gist.github.com/ and puth the link here.

The content of config/config.php:
{
“system”: {
“instanceid”: “ocoq89hwbqzx”,
“passwordsalt”: “REMOVED SENSITIVE VALUE”,
“secret”: “REMOVED SENSITIVE VALUE”,
“trusted_domains”: [
“nas”,
REMOVED SENSITIVE VALUE
],
“datadirectory”: “/media/owncloud/data”,
“overwrite.cli.url”: “REMOVED SENSITIVE VALUE/owncloud”,
“htaccess.RewriteBase”: “/owncloud”,
“dbtype”: “mysql”,
“version”: “10.6.0.5”,
“dbname”: “owncloud”,
“dbhost”: “localhost”,
“dbtableprefix”: “oc_”,
“dbuser”: “REMOVED SENSITIVE VALUE”,
“dbpassword”: “REMOVED SENSITIVE VALUE”,
“logtimezone”: “Europe/Berlin”,
“installed”: true,
“mail_smtpmode”: “smtp”,
“default_language”: “de”,
“trashbin_retention_obligation”: “auto, 30”,
“loglevel”: 3,
“mail_from_address”: “REMOVED SENSITIVE VALUE”,
“mail_domain”: “REMOVED SENSITIVE VALUE”,
“mail_smtpport”: “465”,
“defaultapp”: “files”,
“overwriteprotocol”: “https”,
“updatechecker”: false,
“blacklisted_files”: [
“.htaccess”
],
“enable_avatars”: true,
“asset-pipeline.enabled”: true,
“activity_expire_days”: 365,
“quota_include_external_storage”: false,
“versions_retention_obligation”: “auto, 7”,
“allow_user_to_change_display_name”: false,
“knowledgebaseenabled”: false,
“session_lifetime”: 86400,
“check_for_working_htaccess”: true,
“maintenance”: false,
“log_rotate_size”: 1048576,
“session_keepalive”: true,
“mail_smtpdebug”: false,
“mail_smtphost”: “REMOVED SENSITIVE VALUE”,
“integrity.ignore.missing.app.signature”: [
“theme-mytheme”
],
“cache_chunk_gc_ttl”: 86400,
“skeletondirectory”: “/var/www/html/owncloud/apps/theme-mytheme/core/skeleton”,
“mail_smtpauth”: 1,
“mail_smtpname”: “REMOVED SENSITIVE VALUE”,
“mail_smtppassword”: “REMOVED SENSITIVE VALUE”,
“mail_smtpauthtype”: “LOGIN”,
“mail_smtpsecure”: “ssl”,
“memcache.local”: “\OC\Memcache\APCu”,
“filelocking.enabled”: true,
“memcache.locking”: “\OC\Memcache\Redis”,
“redis”: {
“host”: “localhost”,
“port”: 6379
},
“version.hide”: true,
“upgrade.disable-web”: true
}
}

Log in to the web-UI with an administrator account and click on
'admin' -> 'Generate Config Report' -> 'Download ownCloud config report'
This report includes the config.php settings, the list of activated apps
and other details in a well sanitized form.

or 

If you have access to your command line run e.g.:
sudo -u www-data php occ config:list system
from within your ownCloud installation folder

*ATTENTION:* Do not post your config.php file in public as is. Please use one of the above
methods whenever possible. Both, the generated reports from the web-ui and from occ config:list
consistently remove sensitive data. You still may want to review the report before sending.
If done manually then it is critical for your own privacy to dilligently
remove *all* host names, passwords, usernames, salts and other credentials before posting.
You should assume that attackers find such information and will use them against your systems.

List of activated apps:
Enabled:

  • activity: 2.6.0
  • audioplayer: 2.8.4
  • brute_force_protection: 1.1.0
  • calendar: 1.6.4
  • comments: 0.3.0
  • configreport: 0.2.0
  • contacts: 1.5.5
  • dav: 0.6.0
  • drawio: 0.0.9
  • extract: 1.2.4
  • federatedfilesharing: 0.5.0
  • federation: 0.1.0
  • files: 1.5.2
  • files_clipboard: 1.0.3
  • files_external: 0.7.1
  • files_mediaviewer: 1.0.4
  • files_pdfviewer: 0.11.2
  • files_sharing: 0.14.0
  • files_texteditor: 2.3.0
  • files_trashbin: 0.9.1
  • files_versions: 1.3.0
  • firstrunwizard: 1.2.0
  • market: 0.6.0
  • metadata: 0.10.0
  • notifications: 0.5.2
  • password_policy: 2.1.2
  • provisioning_api: 0.5.0
  • systemtags: 0.3.0
  • templateeditor: 0.4.0
  • theme-mytheme: 2.0.0
  • updatenotification: 0.2.1
    Disabled:
  • encryption
  • external
  • user_external
If you have access to your command line run e.g.:
sudo -u www-data php occ app:list
from within your ownCloud installation folder.

Are you using external storage, if yes which one: local/smb/sftp/…

Are you using encryption: yes/no

Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/…

LDAP configuration (delete this part if not used)

With access to your command line run e.g.:
sudo -u www-data php occ ldap:show-config
from within your ownCloud installation folder

Without access to your command line download the data/owncloud.db to your local
computer or access your SQL server remotely and run the select query:
SELECT * FROM `oc_appconfig` WHERE `appid` = 'user_ldap';


Eventually replace sensitive data as the name/IP-address of your LDAP server or groups.

Client configuration

Browser:

Operating system:

Logs

Web server error log

Insert your webserver log here

ownCloud log (data/owncloud.log)

Insert your ownCloud log here

Browser log

Insert your browser log here, this could for example include:

a) The javascript console log
b) The network log 
c) ...

I cannot confirm this, works perfectly with any sender address.

It’s difficult to say, without knowing the details. But, in case it’s not your own smtp-server: Could it be that your mail provider denies the use of senders from other domains?

1 Like

Hey alfredb!

Thanks for testing. I will check the email notification this weekend with another SMTP account.

Edit: I asked my mail provider and it is a security setting. My sender address domain is not the same as the login smtp address domain. There is no good solution for me.

1 Like

So my suspicion was correct after all.

But why do you want to use another sender address there? Avoid spamming?

1 Like

I have a hoster with a small webspace (15 GB).
At home on a Raspberry Pi runs an ownCloud instance. When I set up the instance at home, I used ddnss.de as DynDNS provider.
So far I haven’t found the motivation to change the main access url to a subdomain from my hoster. Still I want to use an account from the hoster for sending mails
and use cloud@MY.ddnss.de as sender address and not XY@MEINEDOMAIN.de of my domain. So that the user thinks that they were sent from cloud@MY.ddnss.de.

Setting up a mail server on the rpi isn’t an option for me .

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.