OC 9.1.0 Mod Rewrite problem (possibly)

php
webserver_issue

#1

Hello,

I finally managed to install a clean version of OC 9.1.0 (with the help of this board - thank you!)

After the initial set-up, I was logged in and everything was working fine.

Trying to synchronize with desktop client I get:
Access forbidden by server. To verify that you have proper access, click here to access the service with your browser.

And when I try to log in online, it says wrong password.

I have tried searching the forum and looks like .htaccess needs to have RewriteEngine on which I have (the .htaccess that came with the installation).

<IfModule modrewrite.c>_
_ RewriteEngine on_
_ RewriteRule .* - [env=HTTP_AUTHORIZATION:%{HTTP:Authorization}]_
_ RewriteRule ^.well-known/host-meta /public.php?service=host-meta [QSA,L]_
_ RewriteRule ^.well-known/host-meta.json /public.php?service=host-meta-json [QSA,L]_
_ RewriteRule ^.well-known/carddav /remote.php/dav/ [R=301,L]_
_ RewriteRule ^.well-known/caldav /remote.php/dav/ [R=301,L]_
_ RewriteRule ^remote/(.*) remote.php [QSA,L]_
_ RewriteRule ^(build|tests|config|lib|3rdparty|templates)/.* - [R=404,L]_
_ RewriteCond %{REQUEST_URI} !^/.well-known/acme-challenge/.*_
_ RewriteRule ^(.|autotest|occ|issue|indie|db_|console).* - [R=404,L]_

What am I missing here? Please help.

Thank you.


#2

Hi,

there are currently basic info like Apache and PHP version as well as possible error messages from your logfiles missing. All that mandatory stuff is asked in the template shown when creating a new thread.


#3

Steps to reproduce
1. Fresh install of the latest ownCloud (9.1.0) - installation was successful

Expected behaviour
I should be able to log in to my admin account (or any account for that matter) either from web interface or via desktop syc client.

Actual behaviour
Web interface says: Wrong password. Reset it?
Desktop sync client says: Access forbidden by server. To verify that you have proper access, click here to access the service with your browser.

Server configuration
Operating system: CentOS release 6.8 (Final)

Web server: Apache/2.2.15 (Unix)

Database: mysql Ver 14.14 Distrib 5.1.73, for redhat-linux-gnu (x86_64) using readline 5.1

PHP version: PHP 5.3.3 (cli) (built: May 10 2016 21:39:50)
Copyright (c) 1997-2010 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
with the ionCube PHP Loader v4.6.0, Copyright (c) 2002-2014, by ionCube Ltd.

ownCloud version (see ownCloud admin page): (from status.php as I am unable to log in)
{"installed":true,"maintenance":false,"version":"9.0.4.1","versionstring":"9.0.4","edition":""}

Updated from an older ownCloud or fresh install: Fresh install

ownCloud log (data/owncloud.log, see https://central.owncloud.org/t/how-to-find-webserver-or-oc-logfile-enable-php-logfile/808):

Last entries:

{"reqId":"sE22azk5PK9OVOyKP6Pw","remoteAddr":"79.155.40.191","app":"core","message":"Login failed: 'marten' (Remote IP: '79.155.40.191')","level":2,"time":"2016-07-29T14:29:39+00:00","method":"PROPFIND","url":"\/owncloud\/remote.php\/webdav\/","user":"--"}
{"reqId":"kWoE3Qibz7+9822Q9vYw","remoteAddr":"79.155.40.191","app":"core","message":"Login failed: 'marten' (Remote IP: '79.155.40.191')","level":2,"time":"2016-07-29T14:35:43+00:00","method":"POST","url":"\/owncloud\/","user":"--"}
{"reqId":"AKYPi47B8vmY93hhLAOE","remoteAddr":"79.155.40.191","app":"core","message":"Login failed: 'marten' (Remote IP: '79.155.40.191')","level":2,"time":"2016-07-29T14:38:33+00:00","method":"POST","url":"\/owncloud\/","user":"--"}
{"reqId":"3w4dl4EdkdUnk1EU7VLt","remoteAddr":"79.155.40.191","app":"core","message":"Login failed: 'marten' (Remote IP: '79.155.40.191')","level":2,"time":"2016-07-29T14:43:44+00:00","method":"POST","url":"\/owncloud\/","user":"--"}
{"reqId":"3DjgBtuunIvCvzuMWKVN","remoteAddr":"79.155.40.191","app":"core","message":"Login failed: 'marten' (Remote IP: '79.155.40.191')","level":2,"time":"2016-07-29T14:44:17+00:00","method":"PROPFIND","url":"\/owncloud\/remote.php\/webdav\/","user":"--"}
{"reqId":"KWZeCQ5nAvCGpIPETQ3A","remoteAddr":"79.155.40.191","app":"core","message":"Login failed: 'marten' (Remote IP: '79.155.40.191')","level":2,"time":"2016-07-29T14:46:23+00:00","method":"POST","url":"\/owncloud\/","user":"--"}
{"reqId":"LHMx3\/AgvfvoUs+S\/WBl","remoteAddr":"79.155.40.191","app":"core","message":"Login failed: 'marten' (Remote IP: '79.155.40.191')","level":2,"time":"2016-07-29T14:46:35+00:00","method":"POST","url":"\/owncloud\/","user":"--"}
{"reqId":"j4B4gXybAZgkU91ZrQdb","remoteAddr":"79.155.40.191","app":"core","message":"Login failed: 'marten' (Remote IP: '79.155.40.191')","level":2,"time":"2016-07-29T15:01:04+00:00","method":"PROPFIND","url":"\/owncloud\/remote.php\/webdav\/","user":"--"}
{"reqId":"zoEuzvpom7oTmgzzxg2j","remoteAddr":"79.155.40.191","app":"core","message":"Login failed: 'marten' (Remote IP: '79.155.40.191')","level":2,"time":"2016-07-29T15:01:07+00:00","method":"PROPFIND","url":"\/owncloud\/remote.php\/webdav\/","user":"--"}
{"reqId":"xGRhvJA9fpTC4aTLq8JT","remoteAddr":"88.20.75.241","app":"core","message":"Login failed: 'marten' (Remote IP: '88.20.75.241')","level":2,"time":"2016-07-29T15:17:13+00:00","method":"POST","url":"\/owncloud\/","user":"--"}
{"reqId":"ySmEC7d54GDM4A9mATLI","remoteAddr":"88.20.75.241","app":"core","message":"Login failed: 'marten' (Remote IP: '88.20.75.241')","level":2,"time":"2016-07-29T15:17:17+00:00","method":"POST","url":"\/owncloud\/","user":"--"}
{"reqId":"fQzijNA9km3JMYMKjRJs","remoteAddr":"88.20.75.241","app":"core","message":"Login failed: 'marten' (Remote IP: '88.20.75.241')","level":2,"time":"2016-07-29T15:20:10+00:00","method":"POST","url":"\/owncloud\/","user":"--"}
{"reqId":"\/nqXqUdV0ARtUhZ+fKys","remoteAddr":"88.20.75.241","app":"core","message":"Login failed: 'marten' (Remote IP: '88.20.75.241')","level":2,"time":"2016-07-29T15:27:10+00:00","method":"PROPFIND","url":"\/owncloud\/remote.php\/webdav\/","user":"--"}
{"reqId":"jWi2Vti5+Icm3\/YUNT\/F","remoteAddr":"88.20.75.241","app":"core","message":"Login failed: 'marten' (Remote IP: '88.20.75.241')","level":2,"time":"2016-07-29T15:33:03+00:00","method":"PROPFIND","url":"\/owncloud\/remote.php\/webdav\/","user":"--"}
{"reqId":"VDsCVNmr61EoU4wM6OkJ","remoteAddr":"88.20.75.241","app":"core","message":"Login failed: 'admin' (Remote IP: '88.20.75.241')","level":2,"time":"2016-07-29T15:37:30+00:00","method":"POST","url":"\/owncloud\/","user":"--"}
{"reqId":"eCwNqoXAMtEzWyB4HS7Z","remoteAddr":"88.20.75.241","app":"core","message":"Login failed: 'wro' (Remote IP: '88.20.75.241')","level":2,"time":"2016-07-29T15:37:37+00:00","method":"POST","url":"\/owncloud\/","user":"--"}
{"reqId":"u8yOH+dlbY3hHIOwpAIP","remoteAddr":"88.20.75.241","app":"core","message":"Login failed: 'marten' (Remote IP: '88.20.75.241')","level":2,"time":"2016-07-29T15:37:41+00:00","method":"POST","url":"\/owncloud\/","user":"--"}

Special configuration (external storage, external authentication, reverse proxy, server-side-encryption): None

Integrity status for oC9+
I am unable to login.

Login as admin user into your ownCloud and access
http://example.com/index.php/settings/integrity/failed
paste the results here.

#4

Hi,

this doesn't match the info that you have done a clean install of oC 9.1.0. Might be possible that you have two different ownCloud installations on your system.

Could you verify the running PHP version with a phpinfo.php. That seems to be only the version on your command line. ownCloud 9.1.0 won't run on PHP 5.3.3


#5

Than you for your reply.

You're right as I did install - which I thought - was the latest version

CentOS6_SCL_PHP54 owncloud-files-9.0.4-1_

Run the following shell commands as root to trust the repository.

rpm --import https://download.owncloud.org/download/repositories/9.0/CentOS6_SCL_PHP54/repodata/repomd.xml.key_
Run the following shell commands as root to add the repository and install from there.

wget http://download.owncloud.org/download/repositories/9.0/CentOS6_SCL_PHP54/ce:9.0.repo -O /etc/yum.repos.d/ce:9.0.repo_
yum clean expire-cache
yum install owncloud-files

And phpinfo.php shows this on top: PHP Version 5.3.3

What should I do? Please help.

Thank you.


#6

Hi,

a first step is to get your PHP setup to a working state and that it doesn't use such an outdated PHP version. Both, the php command on the command line as well as the phpinfo needs to show PHP 5.4+ before we can continue to debug this from ownCloud side.


#7

Thank you for your response.

I have now upgraded to PHP Version 5.4.45

However, the problem persists. What should I try next?

Thank you for your support!


#8

This is the next step:

If you have two installations (9.0.4 and 9.1.0) its very likely that you have broken something here. I won't continue giving support for such an environment (broken PHP, two installed oC instances) but maybe some one else will continue.


#9

Thank you for your response. I am sorry you will not continue.

Does anyone else have any other ideas?

I don't think at any point I installed 9.1.0 actually, so must be just 9.0.4. (I only ran the commands as per instructions from https://download.owncloud.org/download/repositories/9.0/owncloud/)

I did yum remove owncloud as well and then again yum install owncloud. And I only have database for owncloud.

I did have ownCloud 6.x previosly installed and that was working fine. Maybe that's the second instance? (I did remove that database though) How could I find out and then remove it?

Anyone - any ideas? Thank you.


#10

Let me just try this - what steps do I need to take to remove any and all instances of ownCloud completely from my server?

If I do locate owncloud and then just manually remove all associated files to do with owncloud - will that work?


#11

I can't tell for the yum-packet-manager. But they usually remove the programs and remove no data. So searching for anything in your file system with owncloud and remove it, should help. Also remove old database users and old databases.

Before you reinstall owncloud, make sure that your webserver works and uses php5.4 or higher.


#12

Hello,

Thank you to you both. This did the trick for me and everything is working fine now.

The problem was old version of PHP.

Thanks again!