OC HyperV Appliance - Cannot figure out how to set 16GB file upload

help

#1

Please help us by providing the following info. Before posting please also check the pinned "Known issues" threads and make sure that you're running the latest available version for your oC release: https://owncloud.org/changelog/

Steps to reproduce

I lost the steps I took, so I think this is everything I've done...

  1. Download VHDX appliance from OC.
  2. Configure HyperV - 1Proc, 1GB RAM, Bridged network
  3. Boot OC HV instance, log into the terminal, complete OC server install.
  4. Within the CLI I do the following:
  5. Sudo -i
  6. cd /var/www/owncloud
  7. nano .htaccess
  8. I find and edit upload_max_filesize = 16G
  9. I find and edit post_max_size = 16G save and exit the file
  10. sudo nano /etc/php5/apache2/php.ini
  11. In php.ini find and modify to this
  12. upload_tmp_dir = /var/www/owncloud/data/upload-tmp
  13. upload_max_filesize = 16G
  14. mkdir /var/www/owncloud/data/upload-tmp
  15. chown -R www-data:www-data /var/www/owncloud/data/upload-tmp
  16. service apache2 restart

Expected behaviour
I hope to be able to upload files of upto 16GB via the web.

Actual behaviour
File acts like it is uploading, but then gives error failed to write to disk.

Server configuration
Operating system: Ubuntu 14.04 using OC's HyperV appliance
Web server: Apache
Database:
PHP version:
ownCloud version (see ownCloud admin page): 9.1.2
Updated from an older ownCloud or fresh install: No
Special configuration (external storage, external authentication, reverse proxy, server-side-encryption):

ownCloud log (data/owncloud.log)

Please paste possible errors in the following code block, see https://central.owncloud.org/t/how-to-find-webserver-or-oc-logfile-enable-php-logfile/808 for more info

Integrity status for oC9+

No errors have been found.

#2

You can also change these two in you php.ini. Do you use a 32-bit system? 32-bit php can't handle large uploads (>2 gb).


#3

Thanks for the reply - sorry for the delay in my response.

The HyperV appliance is 64bit.

Rather than changing settings outside of OC, I'd rather change what is necessary just within OC. This can be done, and as I stated above, it acts like it should be uploading, but at the end of the upload, it fails. If it were configured to not accept files over 2gb, it would not even begin the file transfer process.


#4

Some parameters can only be set in your webserver of php config (or you can even disallow scripts to change such limits themselves):
https://doc.owncloud.org/server/9.1/admin_manual/configuration_files/big_file_upload_configuration.html?highlight=big%20file

If you think the default configuration of the VM could be improved, you can suggest changes on github.com/owncloud/vm/issues