OC9 server failed, no access even via occ. initial help required


#1

Hello,
I'm using OC for a couple of years, server setup on my Raspberry pi (raspbian jessie) for family use. It's worked almost without fault so when it failed today I had to re-read the OC 9 manual to remember the admin basics like occ commands.

I googled around and found some similar errors but no resolutions, anhow my initial issue is I cannot get to any debugging without access to occ commands, correct? I'm happy to try debug, provide more info and resolve but need help first in this case.

Thanks in advance.
-->

Steps to reproduce

  1. OC web reports 'internal server error'
  2. sudo -u www-data php occ status and all other commands fails with 'unhandled exception error
  3. tried reboots, check mysql access and apache all seem OK

Expected behaviour

first major failure of OC. no recent upgrades or changes made.
I though the occ command might allow a safemode access

Actual behaviour

all attempt to debug via web and occ fail with 'unhandles exception' error like this:

sudo -u www-data php occ status
An unhandled exception has been thrown:
exception 'OCP\AppFramework\QueryException' with message 'Could not resolve OCA\Files_External\Lib\Backend\FTP! Class OCA\Files_External\Lib\Auth\Password\Password does not exist' in /var/www/html/owncloud/lib/private/appframework/utility/simplecontainer.php:89
Stack trace:

0 /var/www/html/owncloud/lib/private/appframework/utility/simplecontainer.php(104): OC\AppFramework\Utility\SimpleContainer->resolve('OCA\Files_Exter...')

1 /var/www/html/owncloud/apps/files_external/appinfo/application.php(74): OC\AppFramework\Utility\SimpleContainer->query('OCA\Files_Exter...')

2 /var/www/html/owncloud/apps/files_external/appinfo/application.php(45): OCA\Files_External\AppInfo\Application->loadBackends()

3 /var/www/html/owncloud/apps/files_external/appinfo/app.php(44): OCA\Files_External\AppInfo\Application->__construct()

4 /var/www/html/owncloud/lib/private/app.php(163): require_once('/var/www/html/o...')

5 /var/www/html/owncloud/lib/private/app.php(144): OC_App::requireAppFile('files_external')

6 /var/www/html/owncloud/lib/private/app.php(117): OC_App::loadApp('files_external')

7 /var/www/html/owncloud/lib/private/console/application.php(95): OC_App::loadApps()

8 /var/www/html/owncloud/console.php(87): OC\Console\Application->loadCommands(Object(Symfony\Component\Console\Input\ArgvInput), Object(Symfony\Component\Console\Output\ConsoleOutput))

9 /var/www/html/owncloud/occ(11): require_once('/var/www/html/o...')

10 {main}

Server configuration

OC 9 with raspbian jessie on apache and mariaDB

Web server:
apache

Database:
mariaDB 10

PHP version:
php 5.6

ownCloud version: (see ownCloud admin page)
OC 9

Updated from an older ownCloud or fresh install:
updated several times over couple of years

Where did you install ownCloud from:
forgot would have been download and install from website

Signing status (ownCloud 9.0 and above):
I'm the admin and user

Login as admin user into your ownCloud and access 
http://example.com/index.php/settings/integrity/failed 
paste the results into https://gist.github.com/ and puth the link here.

I cannot login.

The content of config/config.php:
withheld sensitive

Log in to the web-UI with an administrator account and click on
'admin' -> 'Generate Config Report' -> 'Download ownCloud config report'
This report includes the config.php settings, the list of activated apps
and other details in a well sanitized form.

I cannot login

or

If you have access to your command line run e.g.:
sudo -u www-data php occ config:list system
from within your ownCloud installation folder

cannot run occ, same error produced

List of activated apps:
cannot run occ, same error produced

**Are you using external storage, if yes which one:** local/smb/sftp/...
yes, smb and nfs folders

**Are you using encryption:** yes/no
no

**Are you using an external user-backend, if yes which one:** LDAP/ActiveDirectory/Webdav/...
not sure

With access to your command line run e.g.:
sudo -u www-data php occ ldap:show-config
from within your ownCloud installation folder

cannot run occ, same error produced

Without access to your command line download the data/owncloud.db to your local
computer or access your SQL server remotely and run the select query:
SELECT * FROM oc_appconfig WHERE appid = 'user_ldap';

Eventually replace sensitive data as the name/IP-address of your LDAP server or groups.

### Client configuration
**Browser:**
IE, Firefox, chrome all same error

**Operating system:**
Ubuntu 17.4, android - same error

### Logs
#### Web server error log
nsert your webserver log here

ownCloud log (data/owncloud.log)

Insert your ownCloud log here

Browser log


#2

Hi,

what is your server configuration? External Storage? LDAP Server?

In the logs there is something of a missing password, maybe a password somewhere has been changed or run out of the expiration time and has to be changed. That would be my first uneducated guess :smiley:


#3

To answer (solve) my own query:

I decided to make a backup and do a update/upgrade on the server.

During upgrade, which took about 20 minutes, the OC restart itself! I only noticed because I was working on another machine Ubuntu with OC client and it went from grey to blue tick status!

I see the upgrade involved Apache2 modules (upgrade to 2.4.10) so I'm guessing this was the issue? Not sure how I can back trace or if anyone is interested.

I'm happy and can close this if I knew how.
Andrew.-


#4

Very nice, an update / upgrade with a backup is always good.

You can't close this, because this is not an ticket :slight_smile:


#5

thanks for your responsed Dmitry. as you see it resolved with upgrade to the raspbian server and I suppose it was apache2 issue rather than passwords etc.

I will review external storage. I only use LAN external HDD's using smb and NFS but have activate the WebDAV, SFPT, google, openstack and dropbox options.

Now I can access the admin facility I can see in the log the WebDAV releated error

Exception: {"Message":"HTTP\/1.1 503 OCP\AppFramework\QueryException: Could not resolve OCA\Files_External\Lib\Backend\FTP! Class OCA\Files_External\Lib\Auth\Password\Password does not exist","Exception":"Sabre\DAV\Exception\ServiceUnavailable","Code":0,"Trace":"#0 [internal function]: {closure}(Object(Sabre\HTTP\Request), Object(Sabre\HTTP\Response))\n#1 \/var\/www\/html\/owncloud\/3rdparty\/sabre\/event\/lib\/EventEmitterTrait.php(105): call_user_func_array(Object(Closure), Array)\n#2 \/var\/www\/html\/owncloud\/3rdparty\/sabre\/dav\/lib\/DAV\/Server.php(446): Sabre\Event\EventEmitter->emit('beforeMethod', Array)\n#3 \/var\/www\/html\/owncloud\/3rdparty\/sabre\/dav\/lib\/DAV\/Server.php(248): Sabre\DAV\Server->invokeMethod(Object(Sabre\HTTP\Request), Object(Sabre\HTTP\Response))\n#4 \/var\/www\/html\/owncloud\/remote.php(69): Sabre\DAV\Server->exec()\n#5 \/var\/www\/html\/owncloud\/remote.php(141): handleException(Object(OCP\AppFramework\QueryException))\n#6 {main}","File":"\/var\/www\/html\/owncloud\/remote.php","Line":67,"User":false}