OCHTTPStatusErrorDomain error 500

Hello everyone.
Everything worked flawlessly until few weeks ago. Now I can only upload files from within the same subnet of the server.
I can smell it is a network issue, but I don’t understand where I should look…
Server cert is valid, DNS is up…

Steps to reproduce

1.Upload a file remotely, with any client (out from private LAN)

Expected behavior

File uploaded as usual

Actual behavior

When I try to upload it from remote I get the error in the title. But this doesn’t happen if I upload the file from an address inside the same subnet of the server. This does happen with any client

Server configuration

Operating system:
Ubuntu Server 18.10

Web server:
Apache 2.4.34


PHP version:

ownCloud version: (see ownCloud admin page)

Updated from an older ownCloud or fresh install:
No update, no fresh. It just started happening

Signing status (ownCloud 9.0 and above):
No errors have been found.

The content of config/config.php:
When I try to generate the config report from remote it gives me network error.

Are you using external storage, if yes which one: local/smb/sftp/…

Are you using encryption: yes/no

Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/…

Client configuration

Any ONLY from outside server subnet

Operating system:


Web server error log

[Fri Sep 18 00:00:01.022329 2020] [mpm_prefork:notice] [pid 13547] AH00163: Apache/2.4.34 (Ubuntu) SVN/1.10.0 OpenSSL/1.1.1 configured -- resuming normal operations
[Fri Sep 18 00:00:01.022349 2020] [core:notice] [pid 13547] AH00094: Command line: '/usr/sbin/apache2'
[Fri Sep 18 13:31:05.196106 2020] [mpm_prefork:notice] [pid 13547] AH00169: caught SIGTERM, shutting down
[Fri Sep 18 13:31:44.899579 2020] [so:warn] [pid 1193] AH01574: module dav_module is already loaded, skipping
[Fri Sep 18 13:31:45.172740 2020] [mpm_prefork:notice] [pid 1288] AH00163: Apache/2.4.34 (Ubuntu) SVN/1.10.0 OpenSSL/1.1.1 configured -- resuming normal operations
[Fri Sep 18 13:31:45.172773 2020] [core:notice] [pid 1288] AH00094: Command line: '/usr/sbin/apache2'

ownCloud log (data/owncloud.log)

File contains normal operations and no log is generated when I upload a file successfully or unsuccessfully

Is there any more information I could provide you with? What does that error even mean?


from what i know a “500” code means an “Internal Server Error”.

Generally i think this is some kind of configuration / network problem because you have provided log files of an Apache web server but if i’m doing an port scan from remote an nginx server is responding:

$ nmap -p 443 -sV cloud.villamoscuzza.com
Starting Nmap 7.80 ( https://nmap.org ) at 2020-09-22 13:16 CEST
Nmap scan report for cloud.villamoscuzza.com (
Host is up (0.063s latency).

443/tcp open  ssl/http nginx

Service detection performed. Please report any incorrect results at https://nmap.org/submit/ .
Nmap done: 1 IP address (1 host up) scanned in 49.18 seconds

Yes, that is correct.
Nginx running a virtual server on cloud.[domain]
Everything worked perfectly until few weeks ago, and even now when DOWNLOADING, as you can check by downloading the file I provided which is sitting nicely on the ownCloud server… but as soon as I can I will try to bypass the nginx server and access with IP address from remote (even if nginx is working flawlessly from local address, when requesting same cloud.[domain] address)

I’ll post my findings ASAP.

Thanks again


maybe the log files of nginx gives some clues then?

Generally i don’t think that this is a problem of ownCloud if the access is working locally but not from remote so i’m not sure if there will be much answers / help for your problem in an ownCloud support forums. :frowning_face:

But maybe you can still post your findings and hope some one familiar with such a setup like yours (nginx + apache) is able to give some more help.

Yup… if I’ll find out the prob is Nginx related, I’ll move out from here and come back when I’ll have a working solution, to help anyone that could ever be in my situation…

1 Like


if you can find some logs from nginx related to this 500 error then think you can still try to post it here so that some one familiar with nginx could have a look at.

I just have also seen the following in the previous logs:

I think this is unrelated to your problem but from what i have read in the past (in this docs provided by the ownCloud people) there might be problems if running a DAV module on the web server hosting ownCloud.

Ok thanks I’ll give it a look and come back ASAP

Aaand the problem solved itself… Darn how much I hate it when it happens!
It could be worth going through the nginx log files, but by now I will simply call it a day.

Thanks again for the support

1 Like