Ocis reads environment variables but not yaml settings

I am having a weird issue with ocis where in my env file I can set an environment variable and it will work, however, if I try to set the same setting through a yaml file it will not work. For example, setting PROXY_ENABLE_BASIC_AUTH=true works and enables basic auth. However, if instead in ocis.yaml is set:

  enable_basic_auth: true

The setting will not be applied and I won’t be able to use webdav.

I really want to use this for role_assignment, but i’m testing with webdav to start.

I think the documentation for ocis needs a complete overhaul…

the same kind of error is with the theming, I read the documentation, tried changing every setting, restarting and doing it over and over to come to the conclusion that ocis apparently didn’t even read my config file, or at least that section of it… it just read the theme from “data/web/assets/themes/owncloud/theme.json” anyway, despite what was in the config…

the example config files would be nice if they were commented, as it is now someone just points you to some other variable… “try this variable”, “this variable is also related to theming”… very much trial and error and if it works you’re lucky…

@Ownsies I could not reproduce the issue. I can enable/disable basic auth by simply changing the value in the ocis.yaml. There is likely another issue in the setup. Some questions to find it:

Can you double check that you added the enable_basic_auth: true line to the existing proxy section? If there are two proxy section in the file this might cause trouble.

Can you double check that PROXY_ENABLE_BASIC_AUTH is not set to false? Environment variables overwrite the yaml entries.

@monkeyfella sorry to hear that. Just to clarify, you are referring to this docu ownCloud Web with Custom Theming ? It should basically work. I have working examples of themes. We are constantly trying to improve our documentation. Maybe you could help us by pointing out what is wrong in the documentation?

1 Like

I ended up fixing it. I deleted it off ocis.yaml created a proxy.yaml file and ensured it wasn’t in that env file. That seemed to work. Though I’m not sure why

1 Like