Onwcloud Updater cURL error 7: Failed to connect to localhost port 443: Connection refused


#1

Hello out there,

I’ve a Problem updating owncloud Server from 9.1.8.2 to the new version: 10
The update is necessary for compatibility with the new PHP Version 7.2.
But when I try to update with the Updater allways get the cURL error 7: Failed to connect to localhost port 443: Connection refused

I wonder about this because when I previously updated from Version 9.0.11 to 9.1.8 the Updater worked fine.

I also tried the following procedure:

  • download Version 10.1.0 (unfortunately couldn’t find a download for the Version 10.0.10 mentioned in the Admin-Panel!!)
  • upload the files on the Server
  • switch on “mainentance”
  • rename old Installation Directory _v9.1.8
  • move the directories /config/ and /data/ in the Installation Directory with the new Version 10.1.0
  • switch off “mainentance” and start the update
    First the installation process starts but after a while it shows the message that the Installation failed and automatically switches to “maintanence mode”

Would be great, if anybody can help me out of this.
My preferred way would be running the Updater sucessfully.

Best regards,
Heiko

Steps to reproduce

  1. Login Owncloud and open Administrator-Panel
  2. Klick on Updater (stable Version 10.0.10)

Expected behaviour

Updating to the new version

Actual behaviour

White Screen displaying: cURL error 7: Failed to connect to localhost port 443: Connection refused

Server configuration

Managed Webhosting, Provider Strato AG

Web server:
Apache/2.4.37 (Unix)
Database:
MySQL5.6.42
PHP version:
PHP 7.0.33
ownCloud version: (see ownCloud admin page)
9.1.8.2
Updated from an older ownCloud or fresh install:
updated from 9.0.11.
Where did you install ownCloud from:
Updater
Signing status (ownCloud 9.0 and above):

  • Der „Strict-Transport-Security“-HTTP-Header ist nicht auf mindestens „15552000“ Sekunden eingestellt. Für mehr Sicherheit wird das Aktivieren von HSTS empfohlen, wie es in unseren Sicherheitshinweisen erläutert ist.
  • Es wurde kein PHP Memory Cache konfiguriert. Konfiguriere zur Erhöhung der Leistungsfähigkeit, soweit verfügbar, einen Memory Cache. Weitere Informationen finden Sie in unserer Dokumentation.
Login as admin user into your ownCloud and access 
http://example.com/index.php/settings/integrity/failed 
paste the results into https://gist.github.com/ and puth the link here.

No errors have been found.

The content of config/config.php:
$CONFIG = array (
‘instanceid’ => ‘xxx’,
‘passwordsalt’ => ‘xxx’,
‘secret’ => 'xxx,
‘trusted_domains’ =>
array (
0 => ‘localhost’,
1 => ‘meindomainname’,
),
‘datadirectory’ => ‘/pfad/htdocs/owncloud8/owncloud/data’,
‘overwrite.cli.url’ => ‘domainname(mit https)/oc’,
‘dbtype’ => ‘mysql’,
‘version’ => ‘9.1.8.2’,
‘dbname’ => ‘DBxxxxxx’,
‘dbhost’ => ‘DBhost Strato Server’,
‘dbtableprefix’ => ‘oc_’,
‘dbuser’ => ‘Userxxx’,
‘dbpassword’ => ‘Dbpassword’,
‘logtimezone’ => ‘UTC’,
‘installed’ => true,
‘mail_from_address’ => ‘info’,
‘mail_smtpmode’ => ‘php’,
‘mail_domain’ => ‘domainname’,
‘overwritehost’ => ‘cosi-fun-tutti.de’,
‘overwriteprotocol’ => ‘https’,
‘theme’ => ‘’,
‘loglevel’ => 2,
‘maintenance’ => false,
‘updater.secret’ => ‘$2y$10$OmYxuHmODPl60pHeOy.vaOEttLhp1QfrHKwlz0.FiDeqCu1dYxWE.’,
);

End of configuration informations