OPENOFFICE inaccessible on Owncloud Vitrual Appliance

apps

#1

Hello,

I am using Owncloud Virtual Appliance, I have installed and enable OPENOFFICE correctly, guess though.

While I select Office from the drop down left up against the corner, I get this following error messages.

Collabora Online unknown error: Client error response [url] https://mydomain.com/hosting/discovery [status code] 404 [reason phrase] Not Found

Please contact the "https://mydomain.com" administrator.

I do not want to use Collabora Online Office rather prefer OPENOFFICE.

Please help me regards to this.

Thanks in advance.


#2

Hi,

can you connect to your appliance via ssh?


#3

Hi Dmitry,

Yes, I can able to connect via ssh 100 percent and use putty for that.

Thank you.


#4

I use putty too :slight_smile:

The problem is: the "Office from the drop down left up against the corner" is the ownCloud's connector to collabora.

We don't have one for only office.

When only office is installed on your system correctly - you should be able to just create documents.

To install only office - you just need to install the app in the univention app center.

Edit: to be sure - I am gonna try to get only office in my appliance working, and get back to you ASAP


#5

Okay, I managed to get it working.

I suppose you are still on the 10.0.3 ownCloud.

To activate Only Office here are the steps:

  • I suppose you have installed the only office app from the univention app store. If not - you would have to do this.

  • Go to ownCloud, and deactivate the collabora app to avoid conflicts.

  • To do this - you can go to market and look for the collabora app and uninstall it.

  • Once you are in market - look for the only office ownCloud app and install it.

  • Then go to ownCloud - settings - general

  • Here you have the only office server settings.

  • You would have to enter something like this:

https://ucs.owncloud.intranet/onlyoffice-documentserver/

  • ucs.owncloud.intranet is my domain name, you would have to adjust it for your domain name.

  • Also it's important to access ownCloud via https and domain name.

  • You can enter the domain name and the ip address of your appliance in windows in the hosts file. If you need help doing this - I could help you out.

  • To access the appliance via https - open a new private window and accept the exeption for the certificate of the appliance.

Now if you go to ownCloud - Files and click on the plus Icon - > document, you should be taken to the only office interface.

Hope it works, if not, I am here to assist you :slight_smile:


#6

Hi Dmitry,

Thank you indeed for your reply again.

As usual, you rock. I can able to get welcome messages of OPENOFFICE via this https://publicip/onlyoffice-documentserver/welcome/ which I have done already before creating this post.

However, Going to Files and click on the plus icon - > is your indeed helpful guidance, appreciate that :relaxed: Now, my OPENOFFICE started to work normally, I would like to add here that, I have disabled collaborative to permanently hide Office Icon from the drop-down left up against the corner.

Any idea how to instruct Owncloud to set OpenOffice as the default app for any documents extensions.

I would like to really thank you for your help and time.


#7

I am glad that I could help you and that only office is now working in your setup :slight_smile:

Quite a few people told me that they like only office better than collabora.

But the decision what to make default is way above my pay grade :slight_smile:

I am just here to help

It would be a good idea though, to disable the "office" icon in ownCloud out of the box, until the user has decided to use collabora. In that way nobody gets confused. Thanks for making me aware of that.


#8

Hi Dmitry,

Thank you again for your reply.

All types of documents except PDF are able to open directly from the ONLY OFFICE while I click on that, however, for PDF, I have to tell Owncloud to open in the ONLY OFFICE. Any suggestions are highly appreciable.

Once, I get a kind reply from you regards to PDF selection, we can gladly mark this post has been solved.

I wish you great success in your endeavours. Hope to see you again.

Thanks, much !!


#9

Hi,

as for now, it's not possible to set a default for PDFs in Only Office.

I forwarded your request to the team at onlyoffice and I will get to you with their answer.

For now, you could download ownCloud's PDF viewer.

You can find it in Market -> Productivity.

It's an ownCloud app to view PDFs.


#10

Hi Dmitry,

I have installed PDF Viewer and it is working now, however, it is opening on the same tab, any settings to make it open in a separate tab?

I am OK to mark this post as solved, or would you want me to wait for your answer from ONLY OFFICE ?

I will be creating the next topic with another post regards to https certificate warnings and as it marked in red and exclamation mark.

Thank you indeed again for your time, help and support.


#11

Hi,

I think there is no setting for the PDF Viewer to open it in a new tab. Sorry.

I received an response from OnlyOffice >> they would include default PDF viewing in their next release.


#12

Hi Dmitry,

Good news, that ONLY OFFICE will include default PDF in their next release.

We will mark this post has been solved.

Thank you very much for your help.


#13

Glad to help

Enjoy the appliance and OnlyOffice :slight_smile: