Owncloud 10.0.2.1 PHP updater

update_issue
updater
update
10

#1

Steps to reproduce

  1. Open terminal and navigate to owncloud directory
  2. Type in "sudo -u www-data php updater/application.php" to run the php script
  3. Wait until it has finished...

Expected behaviour

I was expecting such an output:

sudo -u www-data php owncloud/updater/application.php
ownCloud updater 1.0 - CLI based ownCloud server upgrades
Checking system health.
- file permissions are ok.
Current version is 9.0.0.12
No updates found online.
Done

(Taken from here)

Actual behaviour

Output:

Checking system health
- file permissions are ok.
Current version is 10.0.2.1
cUrl: error 7
Connection timed out updates.owncloud.org

Server configuration

Operating system: Raspbian GNU/Linux 8 (jessie)

Web server: Apache 2.4.10

Database: MySQL 5.5.57

PHP version: 5.6.30

ownCloud version: 10.0.2.1

Updated from an older ownCloud or fresh install: no

Where did you install ownCloud from:

Signing status (ownCloud 9.0 and above):

No errors have been found.

The content of config/config.php:

{
    "system": {
        "instanceid": "ocqbne2uxvbb",
        "passwordsalt": "***REMOVED SENSITIVE VALUE***",
        "secret": "***REMOVED SENSITIVE VALUE***",
        "trusted_domains": [
            "***REMOVED SENSITIVE VALUE***"
        ],
        "datadirectory": "***REMOVED SENSITIVE VALUE***",
        "overwrite.cli.url": "***REMOVED SENSITIVE VALUE***",
        "dbtype": "mysql",
        "version": "10.0.2.1",
        "dbname": "owncloud",
        "dbhost": "localhost",
        "dbtableprefix": "oc_",
        "dbuser": "***REMOVED SENSITIVE VALUE***",
        "dbpassword": "***REMOVED SENSITIVE VALUE***",
        "logtimezone": "UTC",
        "installed": true,
        "mail_smtpmode": "php",
        "memcache.local": "\\OC\\Memcache\\Redis",
        "filelocking.enabled": "true",
        "memcache.distributed": "\\OC\\Memcache\\Redis",
        "memcache.locking": "\\OC\\Memcache\\Redis",
        "redis": {
            "host": "localhost",
            "port": 6379,
            "timeout": 0,
            "dbindex": 0
        }
    }
}

Are you using encryption: no


#2

Hi, can you try this command?

sudo -u www-data php upgrade -vvv


#3

@dmitry It says „Could not open input file: upgrade“.
Did you mean
sudo -u www-data php occ upgrade -vvv?


#4

I can't see the difference between the 2 commands

Care to elaborate?


#5

Sure, I was just confused because there was no occ in your command. I tried it, and again it said OwnCloud is already latest version.
Hm, is there any line in any file that says where to search/download updates? Because I tried curl -v updates.owncloud.org, the answer was a 301 redirect, so I thought that that could be the problem as ownCloud updater throws a „timed out“ error.


#6

Oh, sorry :slight_smile: I totally forgot the occ part.

In the web UI you can switch between the update channels. Also you should check this file:

/etc/apt/sources.list.d/owncloud.list and check the channel you are currently on. You can switch to stable or production.


#7

No problem at all :wink:
It is set to stable at the moment (both the website-client and the file).

I am just wondering why the connection times out when it tries to connect to updates.owncloud.org with curl.

Still no success.


#8

I have no idea either. Honestly it's the first time I hear about someone who tries to curl updates.owncloud.org


#9

So I just reinstalled owncloud (the latest version, 10.3) and everything works fine atm. We'll see on next update...
Thanks for your help! :slight_smile:


#10

Did you had data that you had to import or was it a fresh installation?

Glad to hear that everything went fine


#11

I moved the data on an external storage device while reinstalling OC 10, so it was a fresh installation (I did not copy the data directory but downloaded all the files and uploaded them after the installation).