ownCloud 10.0.5. does not finish setup on Rasbian Stretch


#1

Hi,

I tried to setup ownCloud 10.0.4 and 10.0.5 on a Rasbian 9 Stretch now three times. I followed this Tutorial, however I also checked the ownCloud documentation about the installation process in verfied it for correctness. Unfortunately, the final setup process using the web installer fails without any message. It just keep saying "Finishing setup..." (well the text on the button, for me it is in german). I assume all database entries are written and also the config.php is written. However, there is one line missing:

'installed' => true,

Here the config how it is written:

<?php
$CONFIG = array (
'updatechecker' => false,
'instanceid' => 'oci9gu827tnv',
'passwordsalt' => 'OkKejz8UzJViAB1wZdmMrqciHvdru8',
'secret' => 'tB1amGKv75Sh042h7Z41YKLJmJen37AwCog4RaCYYbFmDrBd',
'trusted_domains' =>
array (
0 => 'XXX',
),
'datadirectory' => '/media/usb-hdd/owncloud/data',
'overwrite.cli.url' => 'XXX',
'dbtype' => 'mysql',
'version' => '10.0.5.4',
'dbname' => 'owncloud',
'dbhost' => 'localhost',
'dbtableprefix' => 'oc_',
'dbuser' => 'owncloud',
'dbpassword' => 'XXX',
);

Changing the installed value to true allows me to use ownCloud but I can't verify if it is installed correctly, can I? For instance is the sync using the Windows App super slow (I actually think is is only the upload). But this could be another issue. It is not related to network and hardware support of the Raspberry Pi, also already did some Benchmarking.

Also tried to run ownCloud 7 using Rasbian Jessy - it was working.

Are this known issues?


#2

Hey can you show us your owncloud.log from the installation? There should be some hints in here as to why the install did not complete properly.


#3

{"reqId":"SoD6M72c4hGzjQ1g3dEg","level":3,"time":"2018-01-27T04:01:52+00:00","remoteAddr":"46.84.196.43","user":"--","app":"mysql.setup","method":"POST","url":"\/owncloud\/index.php","message":"Specific user creation failed: An exception occurred while executing 'SELECT user FROM mysql.user WHERE user=?' with params [\"oc_Erik\"]:\n\nSQLSTATE[42000]: Syntax error or access violation: 1142 SELECT command denied to user 'owncloud'@'localhost' for table 'user'"}

Edit:
I fixed this problem with the user permissions. Now, there isn't any message anymore in the logfile but it still fails.

In the meanwhile, I set up ownCLoud on Debian Jessie on another sd card and it's working there.