ownCloud 10.0.8 and email problems

10

#1

Hello everyone, I was wondering if you could give me a hand overcoming the email issue out of ownCloud I am faced with. I have tried just about every combination I can think of to get it to successfully relay off an Exchange server on the same network. I have plenty of other devices and applications that relay just fine using similar settings. A Qnap, FreeNAS server, etc… I keep just getting this error in the admin interface of ownCloud:

“A problem occurred while sending the email. Please revise your settings. (Error: Connection could not be established with host mail.example.com [ #0])”

I’ve confirmed the OS can successfully resolve the URL to the correct internal IP of Exchange and that the mechanism accepts connections when manually testing via telnet from other Windows systems on the same network.

This is a fresh Ubuntu Server 16 LTS deployment. Only installed software are the ownCloud prerequisites from the manual install instructions. I’ve seen some chatter about using SSMTP as a work around, but I am not having any luck. Linux is not my first OS, so I don’t have a bunch of experience to draw from. There was also some talk about using sendmail, again I wasn’t successful. Sendmail seemed very involved for a simple SMTP mail forward to a smart host.

I have tried configuring the Exchange server to accept connections for relay even without authentication and the test just fails instantly. Any ideas?

Regards,
Adam Tyler


#2

Maybe the target server is rejecting the connections for some reason. You can try to use a different more permisive target to verify there is no problem with ownCloud, and it’s a setup problem.